[Solved] World fails to save: Accessed from another location - But isn't

Hey there, I’ve got a problem with saving worlds/dimensions on Sponge servers. I’ve tried to pin down the source since some weeks now and I’ve got to the point where I’m straight guessing. Thus I figured I’d also ask you for help or ideas.

First something about our setup:
Running on a dedicated Ryzen root, SSD and Ubuntu 17.04 on GNU/Linux 4.10.12-041012-generic x86_64.
java version “1.8.0_131”
Java™ SE Runtime Environment (build 1.8.0_131-b11)
Java HotSpot™ 64-Bit Server VM (build 25.131-b11, mixed mode)

Reproduced also on Windows 10 (Creators Update).
I’ve tested on various versions of SpongeVanilla API 5. Mostly on “BETA-385”. [Since the mixins are broken on the latest builds I wasn’t able to test with those]
This issue does NOT appear with Forge(-only) or Spigot servers.

After some™ time the Sponge server fails to save dimensions throwing (or more spamming) very helpful messages about the save directory being used from another location. I can guarantee that no other server (or Minecraft instance) is running on the entire machine though. I’ve tried to change the file header limitations as some Google results pointed out that Minecraft may have problems with Linux due to them but neither did that change anything nor does this apply for Windows.
I’ve also yet to find a way of reproducing this with a 100% certainty but may edit this post if that happens.

I’ve got a full (spamming stripped) error log here for you: [14:47:19] [main/INFO] [LaunchWrapper]: Loading tweak class name org.spongepower - Pastebin.com (Messages start at L3190).

Some notes:
The server is restarted once a day and while the issue appears often it sometimes just doesn’t.
The issue appears regardless of any user being on or having joined the server (since start) at all.

While the server uses a custom plugin to create worlds at runtime (whichs code you can see here https://gitlab.com/fearnixxgaming/MCSUtils/blob/refactor/src/main/java/de/fearnixx/sponge/mcsutils/world/commands/WorldCreateCommand.java#L200 ) the issue does also appear when using different world generation plugins.

If you require any more information just tell me as I’ll be happy to provide that.

I’m looking forward to your responses and hope that we are able to figure out what’s going on here.

Thanks for (at least ^^) reading,

  • Mark