[SOLVED] World not in GZIP Format?

Idk what happend but when ever my server starts it crashes with this.

i dont know what started it but it seems to be the world and any backups say the same thing. and it only recently started happening

This sounds like a corruption, more than a Sponge issue.

The stacktrace says that InventoryTweaks and Sponge are being used - can you give us any more information?

Sponge and Forge version would be helpful, as well.

not really thats all im getting but i think i fixed it soz should continued to try fixing it before posting it ^^" tho im unsure of what caused the curruption ._. >.< feel free to close this or delete either or sorry for the uneeded post

I’ll mark it solved, but I’m leaving the topic open in the case that anyone else wants to chime in.

I got this error too two days ago!!! I had to delete the world. Not sure if this is a coincidence or a Sponge/Forge bug.
I believe this happened after updating Sponge. Not sure.
Edit: This is my latest.log file of that day (The server was running Forge, SpongeForge and my custom plugin) http://pastebin.com/PuqUxL0x
And here is the crash report http://pastebin.com/TepitV45