Sponge error: world and mixinout

I tried all the methods, removed FoamFix and BetterFPS (without them the same error), changed the name of spongeforge…


Forge version: forge-1.12.2-
Sponge version: spongeforge-1.12.2-2838-7.1.10-RC3994

I tried to run it without plugins, removed some mods that affect the loading of the world. Tried to allocate less or more RAM, doesn’t help.

Also debug.log: https://gist.github.com/FalcionML/a0ff9b4ac15c151bf67784913a7521de

One more thing you could do is try the latest Recommended Build of SpongeForge, rather than using the latest release candidate. Although there may be more recent bug-fixes in the Release Candidates, they may also be a lot less stable - we don’t always get everything right on the first try. That’s the essence of the difference between a RB and a RC of SpongeForge.
If that also fails, this issue needs to be reported on the SpongeForge issue tracker on GitHub.

Hi !
I’m using the latest Recommended Build of SF and I have the same error as he has.

Disabled some of foamfix configuration as listed, just can’t launch on Forge 1.12.2 - 2838

Have you tried changing the name of spongeforge to _aspongeforge. This should make it load first

1 Like

Does that mean we have to wait for HammerCore to get updated?

You could try disabling the issue.

Tick slip is intended to work with any tile entity from any mod. I added a config to disable this feature, and won’t do any more on my side either.

But it looks like the owner of the mod is not reversing the changes anytime soon, meaning that waiting for an update is not going to fix the issue.

If disabling the issue code doesn’t work then your only options is to either remove the mod or downgrade it

Yeah but this is where it gets interesting : there are no config yet to disable that specific feature. I’ve heard that Just Enough IDs was also messing with SpongeForge.

Ah but there is a config file. Its just not in the normal position. Its in the following


Inside that you need to disable the following (disable by changing true to false)

<entry key="World.ITickable.Override">true</entry> 

And you also need to be on HammerCore as that has the fix for sponge

1 Like

Got it. Thanks! It wasn’t mentionned on the issue report on GH