Sponge Issues on OSX

Sponge on Mac

Recently I began to try to program SpongePlugins on my MacBook. Therefor I created a sponge server and an example plugin. In the plugin I defined a Logger and in the onInitialize(GameInitializationEvent event) method I tried to log a message. As I started the server after building the Jar via Gradle into the mods folder, but as i started the server nothing happened. A /test command didn’t work and wasn’t even registered. Starting the plugin on a windows machine did work and the log and the command were executed. I don’t know any reason of the issue, I tried to export the plugin manually, nothing works. Now I want to know, if this is my fault or if not, if there will be any fix of this. I can send further informations if needed, I have no clue about this whole thing and I hope, one of the Sponge “Pros” :wink: will help. Thank you very much for your effort.

The following text contains the code:

The Main-Class code

package main;

import org.slf4j.Logger;
import org.spongepowered.api.Sponge;
import org.spongepowered.api.command.spec.CommandSpec;
import org.spongepowered.api.event.Listener;
import org.spongepowered.api.event.game.state.GameInitializationEvent;
import org.spongepowered.api.plugin.Plugin;
import org.spongepowered.api.text.Text;

import com.google.inject.Inject;

@Plugin(id = "splittermon-plugin", name = "Splittermond Plugin", version = "0.0.0-DEV")
public class ExamplePlugin {
	// -#- Logger -#-
	private Logger logger;
	public Logger getLogger() {
		return logger;

	public void onInitialization(GameInitializationEvent event) {
		logger.info("Loading. . .");
		CommandSpec spec = CommandSpec.builder()
				.description(Text.of("Test command"))
				.executor(new TestCommand())
		Sponge.getCommandManager().register(this, spec, "test");

The TestCommand

package main;

import org.spongepowered.api.command.CommandException;
import org.spongepowered.api.command.CommandResult;
import org.spongepowered.api.command.CommandSource;
import org.spongepowered.api.command.args.CommandContext;
import org.spongepowered.api.command.spec.CommandExecutor;
import org.spongepowered.api.text.Text;

public class TestCommand implements CommandExecutor{

	public CommandResult execute(CommandSource src, CommandContext args) throws CommandException {
		return CommandResult.success();


We have quite a few developers using Mac OSX so hopefully someone will recognize the issue.

I’m absolutely surprised that you got no error message at all. Are you able to run SpongeForge from the command line, as well as checking all relevant log files, also I hate to say it, but make sure the EULA is accepted?

1 Like

I know my mistake now. I think its absurd, but just downloading the newest experimental build actually helped. My server was built on the latest stable release of forge 1.12.2 and Sponge also. I didn’t even think about searching the problem at this point. I was absolutely sure the newest Forge release and the newest Sponge release would fit together. :grin:

So I am sorry for wasting your time, thank you for the message tot triple-check everything and I think, I can go on now… :+1:

The funny thing about that is, that I’ve downloaded the exact same versions of Sponge and Forge both on Windows and Mac. I am totally not sure, why the operating system makes a difference, its both based on Java so there shouldn’t be any difference…

I’m happy you solved your issue!

Operating system shouldn’t make a serious difference as long as you have an appropriate version of Java on both.

But there should have been some kind of error, or log.

How were you running the server? Just double clicking? Because the normal GUI is removed because it sucks a ton of performance out, and 99% of minecraft servers run from the command line.

I start the server via command-line: java -jar forge-...-universal.jar both on OS and Windows. The server was starting normally on both operating systems, but only Windows noticed my TestPlugin in the mods folder. On Mac the server started simply without loading my plugin…

What is the exact name of the jar file? It’s possible there were some filename issues.

I did double check and copypaste the filename, this was no problem…