Sponge Javadocs & Downloads

Our downloads site is now operational and stable again

You can get all of our builds from https://spongepowered.org/downloads.

Our Javadocs site is still down

You can download 1.12.2 API javadocs from https://www.spongepowered.org/downloads/spongeapi/stable/7 (use your favourite decompression program to extract the javadocs jar).


The direct links have now been removed, please get your builds from the links above. The explanation of what happened remains below.


A Slightly More Detailed Explanation

As you may be aware, we are currently experiencing major issues with the Downloads and Javadocs sites. While we thought that the underlying issues would be quick to fix, unfortunately the problems go much deeper, requiring our infrastructure team to set aside a large block of time to fix the issues and restore everything to working order. As we are a volunteer project, and they too are volunteers, this does require them to fit this in around their other commitments, which is why this has taken longer than everyone would like. Rest assured, they are working on it!

The good news is that all of our downloads are not gone! For plugin developers, Maven still works as usual, so using the API in your project as we recommend will still work. It is just the website that is misbehaving - hence why you might now be on this page!

We are working on it and we hope to get it back soon so that you can also download other releases as required. We thank you for your patience and apologise for any inconvenience caused.

4 Likes

That is for MC 1.12.2 (for forge version 2838 - latest forge 1.12.2)

What version of Forge are you wanting it for? (1.12.2 isnt a actual forge version).

As for how early it started, the earliest build you can get is for MC 1.8

Hello, the spongeforge download does not seem to be working with my server which is running the roguelike dungeons modpack for 1.12.2.

Looking at the forge version that comes with that pack, the sponge link provided is compatible. Meaning its probably a mod incompatibly.

Create a new post with a log (put the log in pastebin and send the link here) so we can take a look at whats happening. Most incompatibles can be fixed with a simple change in a configuration file.

Hello. I was able to make Sponge work, yet there is one problem. I’m running RLcraft on my server. When activated, Sponge seems to glitch some of the mobs where you can’t shift click without being stuck in the air. This was an issue recently with RLCraft’s older version, but it was fixed in this one (2.8.2). So does Sponge revert this somehow back to an older version? Any comments?

Thanks

anyone here got a link to 1.12.2-2838-7.1.7 the server logs are saying i need this particular version in order for it to boot and when i try starting the server with the latest version the server keeps getting a fatal error and crashing.

edit: its not anything else because when i try launching after removing spongeforge it works fine

If the server is requesting a particular type of sponge, that normally means the mod sending the message needs updating. But here you go

https://repo.spongepowered.org/maven/org/spongepowered/spongeforge/1.12.2-2838-7.1.7/spongeforge-1.12.2-2838-7.1.7.jar

Thank you, server is working perfectly fine now.

1 Like

Before you comment gets lost in comments. Personally im not sure whats going on. However I will tell you this.

Sponge does not revert mods to previous versions.

I would create a dedicated thread for your issue (and provide a log to your server as that helps work out whats going on) as comments to a thread (such as this) are supposed to be related. In this case related to the download issue.

As for my theory on whats going on based on your description is that the fix the mod developer has done uses somewhat dangerous code, such as async whereby the sponge cause tracker (that tracks everything happening on the server) couldnt work out what to make of it so it either cancelled the RLCraft fix (not sure if sponge does that) or the tracker changed a value, resulting in RLCraft to crash (a log would confirm that)

Hello, only a link 1.12.2 version of the file, I need a 1.8 11.14.4.1563 version of the file, can be sent to me, please? Thank you!

https://repo.spongepowered.org/maven/org/spongepowered/spongeforge/1.8-1563-2.1-DEV-814/spongeforge-1.8-1563-2.1-DEV-814.jar (removed by Sponge)

https://files.minecraftforge.net/maven/org/spongepowered/spongeforge/1.8-1563-2.1-DEV-814/spongeforge-1.8-1563-2.1-DEV-814.jar

That is the only build I see specifically for 1563, you can use https://spongedl.neptunepowered.org/1.8/1.8/ to see what builds are available from the Maven metadata.

I’m assuming that you realise that this build is extremely old, on both an unsupported API version (2.x) and Minecraft version - so you will not receive any support for this build.

Hi is it possible for me to get a download of spongeforge for forge version 14.23.5.2847?

The supplied builds work fine, just try them.

[mixin]: MixinEnvironment::setCompatibilityLevel is deprecated and will be removed. Set level via config instead!

Getting this error, currently installed with forge 14.23.5.2838.

Should I switch to .4.2838 or? ( Edit: Just realized that that doesn’t exist.)

It’s not an error, it’s a warning. Don’t worry about it.

Yeah I fixed it by updating one of the mods in my mods list!

I need a download for this as 1.7.10, I would hope you have that since most mods run on that version, and I can’t get mods and plugins to work together but my mods run on 1.7.10… If there is none for 1.7.10, is there something else to help mods and plugins work together for that version?

Sponge was created on minecraft 1.8, so sadly there is no version for 1.7.10.

Most mods have been targetting 1.12.2 for the longest time. They have started to focus on 1.15 now, but its still getting there. I havent seen a mod that has a 1.7.10 and not a 1.12.2 mod for a long time.