Sponge Javadocs & Downloads

Hello, the spongeforge download does not seem to be working with my server which is running the roguelike dungeons modpack for 1.12.2.

Looking at the forge version that comes with that pack, the sponge link provided is compatible. Meaning its probably a mod incompatibly.

Create a new post with a log (put the log in pastebin and send the link here) so we can take a look at whats happening. Most incompatibles can be fixed with a simple change in a configuration file.

Hello. I was able to make Sponge work, yet there is one problem. I’m running RLcraft on my server. When activated, Sponge seems to glitch some of the mobs where you can’t shift click without being stuck in the air. This was an issue recently with RLCraft’s older version, but it was fixed in this one (2.8.2). So does Sponge revert this somehow back to an older version? Any comments?

Thanks

anyone here got a link to 1.12.2-2838-7.1.7 the server logs are saying i need this particular version in order for it to boot and when i try starting the server with the latest version the server keeps getting a fatal error and crashing.

edit: its not anything else because when i try launching after removing spongeforge it works fine

If the server is requesting a particular type of sponge, that normally means the mod sending the message needs updating. But here you go

https://repo.spongepowered.org/maven/org/spongepowered/spongeforge/1.12.2-2838-7.1.7/spongeforge-1.12.2-2838-7.1.7.jar

Thank you, server is working perfectly fine now.

1 Like

Before you comment gets lost in comments. Personally im not sure whats going on. However I will tell you this.

Sponge does not revert mods to previous versions.

I would create a dedicated thread for your issue (and provide a log to your server as that helps work out whats going on) as comments to a thread (such as this) are supposed to be related. In this case related to the download issue.

As for my theory on whats going on based on your description is that the fix the mod developer has done uses somewhat dangerous code, such as async whereby the sponge cause tracker (that tracks everything happening on the server) couldnt work out what to make of it so it either cancelled the RLCraft fix (not sure if sponge does that) or the tracker changed a value, resulting in RLCraft to crash (a log would confirm that)

Hello, only a link 1.12.2 version of the file, I need a 1.8 11.14.4.1563 version of the file, can be sent to me, please? Thank you!

https://repo.spongepowered.org/maven/org/spongepowered/spongeforge/1.8-1563-2.1-DEV-814/spongeforge-1.8-1563-2.1-DEV-814.jar (removed by Sponge)

https://files.minecraftforge.net/maven/org/spongepowered/spongeforge/1.8-1563-2.1-DEV-814/spongeforge-1.8-1563-2.1-DEV-814.jar

That is the only build I see specifically for 1563, you can use https://spongedl.neptunepowered.org/1.8/1.8/ to see what builds are available from the Maven metadata.

I’m assuming that you realise that this build is extremely old, on both an unsupported API version (2.x) and Minecraft version - so you will not receive any support for this build.

Hi is it possible for me to get a download of spongeforge for forge version 14.23.5.2847?

The supplied builds work fine, just try them.

[mixin]: MixinEnvironment::setCompatibilityLevel is deprecated and will be removed. Set level via config instead!

Getting this error, currently installed with forge 14.23.5.2838.

Should I switch to .4.2838 or? ( Edit: Just realized that that doesn’t exist.)

It’s not an error, it’s a warning. Don’t worry about it.

Yeah I fixed it by updating one of the mods in my mods list!

I need a download for this as 1.7.10, I would hope you have that since most mods run on that version, and I can’t get mods and plugins to work together but my mods run on 1.7.10… If there is none for 1.7.10, is there something else to help mods and plugins work together for that version?

Sponge was created on minecraft 1.8, so sadly there is no version for 1.7.10.

Most mods have been targetting 1.12.2 for the longest time. They have started to focus on 1.15 now, but its still getting there. I havent seen a mod that has a 1.7.10 and not a 1.12.2 mod for a long time.

Yeah I am using the dragon block C mod and made a server specifically so that I can use a custom form plugin and it wont work, IDK if I need this for that purpose or if I did something wrong but the tutorial I watched said that was how to make them work together and I was going to try the 1.8 version just incase but it says 404 not found

that’s interesting, there are versions linked in the Maven metadata that have seemingly been removed :frowning:

edit: It looks as if someone at Sponge has deleted all the 1.8 versions, I’ve fixed https://spongedl.neptunepowered.org/