Sponge Not Detected 1.12.2

Any help would be greatly appreciated here, I am using spongeforge-1.12.2-2838-7.1.7 with forge-1.12.2-14.23.5.2847-universal and whenever I load up my server there are 0 errors. I try to do /sponge and it just doesn’t know what it is, I have tried maybe 10 different versions of spongeforge now with no luck. I can’t think of anything else to try though.

Two suggestions: try using the latest Recommended Build of SpongeForge, 1.12.2-2838-7.1.9 (from https://www.spongepowered.org/downloads/spongeforge/stable/1.12.2), and prefix the spongeforge filename with with a_ to make it load before other mods (this can help avoid mixin conflicts).

If that doesnt work. Send us a log. Sometimes forge will state why its not loading a mod

That worked, thank you guys for the help!

1 Like

[12:09:21] [Server thread/INFO]: Starting minecraft server version 1.12.2
[12:09:21] [Server thread/INFO]: Loading properties
[12:09:21] [Server console handler/ERROR]: Exception handling console input
java.io.IOException: Неверный дескриптор
at java.io.FileInputStream.readBytes(Native Method) ~[?:1.8.0_51]
at java.io.FileInputStream.read(Unknown Source) ~[?:1.8.0_51]
at java.io.BufferedInputStream.read1(Unknown Source) ~[?:1.8.0_51]
at java.io.BufferedInputStream.read(Unknown Source) ~[?:1.8.0_51]
at sun.nio.cs.StreamDecoder.readBytes(Unknown Source) ~[?:1.8.0_51]
at sun.nio.cs.StreamDecoder.implRead(Unknown Source) ~[?:1.8.0_51]
at sun.nio.cs.StreamDecoder.read(Unknown Source) ~[?:1.8.0_51]
at java.io.InputStreamReader.read(Unknown Source) ~[?:1.8.0_51]
at java.io.BufferedReader.fill(Unknown Source) ~[?:1.8.0_51]
at java.io.BufferedReader.readLine(Unknown Source) ~[?:1.8.0_51]
at java.io.BufferedReader.readLine(Unknown Source) ~[?:1.8.0_51]
at nz$2.run(SourceFile:100) [server.jar:?]
[12:09:21] [Server thread/INFO]: Default game type: SURVIVAL
[12:09:21] [Server thread/INFO]: Generating keypair
[12:09:22] [Server thread/INFO]: Starting Minecraft server on *:25565
[12:09:22] [Server thread/INFO]: Using default channel type
[12:09:22] [Server thread/WARN]: **** SERVER IS RUNNING IN OFFLINE/INSECURE MODE!
[12:09:22] [Server thread/WARN]: The server will make no attempt to authenticate usernames. Beware.
[12:09:22] [Server thread/WARN]: While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
[12:09:22] [Server thread/WARN]: To change this, set “online-mode” to “true” in the server.properties file.
[12:09:22] [Server thread/INFO]: Preparing level “world”
[12:09:23] [Server thread/INFO]: Loaded 488 advancements
[12:09:23] [Server thread/INFO]: Preparing start region for level 0
[12:09:24] [Server thread/INFO]: Preparing spawn area: 68%
[12:09:24] [Server thread/INFO]: Done (1,634s)! For help, type “help” or “?”
[12:09:37] [Server thread/INFO]: hmnrl123[/192.168.1.60:50942] logged in with entity id 212 at (-221.32509739551188, 78.0, -31.479642171954577)
[12:09:37] [Server thread/INFO]: hmnrl123 joined the game
[12:10:41] [Server thread/INFO]: hmnrl123 lost connection: Disconnected
[12:10:41] [Server thread/INFO]: hmnrl123 left the game
[12:10:52] [Server thread/INFO]: Stopping server
[12:10:52] [Server thread/INFO]: Saving players
[12:10:52] [Server thread/INFO]: Saving worlds
[12:10:52] [Server thread/INFO]: Saving chunks for level ‘world’/overworld
[12:10:52] [Server thread/INFO]: Saving chunks for level ‘world’/the_nether
[12:10:52] [Server thread/INFO]: Saving chunks for level ‘world’/the_end
[12:10:52] [Server Shutdown Thread/INFO]: Stopping server
[12:10:52] [Server Shutdown Thread/INFO]: Saving players
[12:10:52] [Server Shutdown Thread/INFO]: Saving worlds

mods are not loaded on my server even with sponge
HELP

Your sponge isnt being detected. The log says “Invalid descriptor” (according to Google translate) which seems to be blocking all loading of mods.

Remove all mods and plugins from your mods folder except spongeforge (if it is SpongeVanilla then please say and attempt to load without any mods in). And send the log again (this time in a pastebin and just send the link - helps with formatting)

Also what version of sponge are you trying to load? And what forge version are you using? Im seeing no mention (if you are using SpongeVanilla then please say too)