Sponge server more RAM (using already java 64-bit)

Hey there,

if I run serverstat of nucleus-plugin it tells me the following:

Average TPS for session: 19.99/20.00
[11:48:29] [pool-2-thread-1/INFO]: Server Uptime: 1 minute, 5 seconds
[11:48:29] [pool-2-thread-1/INFO]: JVM Uptime: 2 minutes, 1 second
[11:48:29] [pool-2-thread-1/INFO]:
[11:48:29] [pool-2-thread-1/INFO]: Maximum allocatable memory: 2677 MB
[11:48:29] [pool-2-thread-1/INFO]: Allocated memory: 1535 MB
[11:48:29] [pool-2-thread-1/INFO]: Utilised memory: 896 MB (58% of allocated, 33% of max)
[11:48:29] [pool-2-thread-1/INFO]: Free (but allocated) memory: 639 MB

The thing is in my start_server.sh I start the server with 6G (of 12GB total) RAM.

java -jar forge-1.11- -xmx6G -xms6G

I have openjdk 8 64-bit installed.

openjdk version "1.8.0_111"
OpenJDK Runtime Environment (build 1.8.0_111-8u111-b14-2~bpo8+1-b14)
OpenJDK 64-Bit Server VM (build 25.111-b14, mixed mode)

So, why it runs with just 2.5 GB of ram? :confused:

I use spongeforge-1.11-2178-6.0.0-BETA-1999 but I don’t think its an generally problem of sponge.


1 Like

It might be allocating less because the arguments need to have an uppercase x (X) like this: -Xmx6G -Xms6G (from my own experience).

1 Like

Thx for ur quick answer, but I changed it and the issue is still existing.

Try java -Xms6G -Xmx6G -jar forge-1.11-

1 Like

Thx @Yeregorix, it fixed it! ;]