Sponge server wont start

Hi I have been unable to get sponge to run with my server and I can not figure out why, any advice?

Forge Version: 1.8.9-
Sponge Version: 1.8.9-1722-3.1.0-BETA-1102

Error Log: http://pastebin.com/WsgiKVU1

Which SpongeForge version are you running?

Please provide the full log.

post updated with versions

Your version of Sponge is quite out-of-date. Can you update to the latest SpongeForge?

where can i find the latest version when i try to click the download from the latest announcment it gives me 1.8-1577

The announcement should be pointing to: spongeforge

the latest recommended version is the one im using should i update to the latest version?

Yes, you should always try as there are a great many bug fixes between the latest recommended and the latest build.

Still Erroring main post completly updated with versions and error log

Actually, try starting the server with SpongeForge and re-add each mod one by one until it stops starting up, tell me which mod it is.

From the full log, there are these coremods being loaded:

The issue here is that one of these core mods (aside from Sponge) is loading the Block class before SpongeForge is able to transform the class as well (which is where basically all of the Block API originates from). The ONLY workaround for now is to rename the sponge forge jar to [[[[1.8.9_spongeforge.jar. HOWEVER, it would be really helpful if you were to help us find which one of the coremods is offending the contracts by doing as I said earlier, which is installing each one of these core mods in order.

working on that will update when i have a anwser

renaming had no effect

Problematic mod is Thaumic Infusion

Please update Thaumatic Infusion, there was a compatibility issue that was recently fixed

You want to get version 4.76 http://minecraft.curseforge.com/projects/thaumic-infusion/files/2276547

Thank you for that though now it gives me a new error:

One or more of your plugins is outdated and does not support SpongeAPI 3.0.0. Try to identify that plugin (could be more than one), update it if possible otherwise you’ll have to remove it for now.

i removed the two plugins i had and got the same error come to realize that it was the IronChest mod causing the problem. I have removed that and am now working on the next error that has appeared having to do with biomes and chunks.Seems im doomed to have a non working sponge server

ok fixed the worldgen error had to disable sankaras from generating from RandomThings but now im getting a error i just do not understand. I apologize for being such a pain.

Problem seems to be solved i Updated thaumcraft and it appears to be working now. thank you for everyones help getting this to work

1 Like