SpongeBootstrap Does not Appear to Work


#1

Hello,

I recently tried installing SpongeForge for its optimizations, and was swiftly met with a crash. A quick Google search told me it was most likely from AE2 (Which I do). Luckily, I can get SpongeBootstrap to force SpongeForge to load first! However, I was met with the same error: https://pastebin.com/cpmCVXSc

Based on lines 8 & 9, SpongeBootstrap appears to work. However, I still get an error which as far as I know should not be possible when I’m using it first. Can anyone give me an idea of what I’m doing wrong?


#2

There are a couple of tweaks that need to be applied to FoamFix to make it work with SpongeForge.


Have you applied those as well?


#3

Thank you for your advice. I did not already make those changes, and just did, but unfortunately I got the same error. Is there a place where I can look up all mod compatibility issues discovered so far, and their solutions? I looked, but couldn’t find a page like that.

I also realized I was not using the recommended version of Forge, so I switched but still got the same error. If it helps, I am using RC3718, since one of the mods our modpack includes requires a more recent version of Forge than the recommended release.

In case there actually was something different about the error, I created another pastebin: https://pastebin.com/70V6fdRL

EDIT:
So, since I had nothing better to do with my time (I’m not joking, I literally had nothing better to do with my time), I sorted through my mods and the error log myself (I am too used to logs that need a special tool to be read, like Skyrim’s papyrus logs, it didn’t even occur to me to look at it beyond the crash report myself). I discovered that LibrarianLib is the one conflicting. Furthermore, I discovered that the conflict began with 4.17 (There is no 4.16 release, so the most recent working version is 4.15).

It appears that one of the mods I run requires a more recent version of LibrarianLib to run properly. I really hope there is a way to use the most recent version of LibrarianLib, because I was already wary of using an older version of the mod for the same version of minecraft, and I’m even more worried now that it’s causing a cascading effect.


#4

This is known issue that is being worked on I believe


#5

this issue is on LibrarianLibs end and out of Sponge’s control, there is no known fix
see https://github.com/TeamWizardry/LibrarianLib/issues/99 for the most recent updates on the matter