SpongeForge 1.12.2 Crash


#1

When i run the server nothing happens.

Versions

Minecraft: 1.12.2
Sponge: 1.12.2-2768-7.1.5
Forge: 1.12.2-14.23.5.2768

Log

https://hastebin.com/kekidefoso.md


#2

It says “failed to bind port” this means another application (maybe another server that you didn’t shut down correctly) is using the port selected.

You can either change the port (will need to change the port your connecting to with minecraft too) or find out whats using the port to begin with and shut it down.

Note: you are currently trying with port 25565 which is the default port of minecraft, this typically means that another minecraft server is running where you have closed the terminal (command prompt) but not the server.
If this is the case you should be able to connect to your server anyway and if you have the permission, run the command “stop” to safely shutdown the server. If you don’t have permission then you will need to kill the task (which can corrupt worlds and maybe other things). The simplest way to kill a task no matter what pc your on is to simply restart the computer, however if your familiar with Task Manager (on Windows) or your O.S alternative, you will be able to task kill the Java application.


#3

Thanks! It worked.