Spongeforge 1.8 server direct crash!

I DID EXACTLY AS U SAID BUT STILL IM GETTING CRASH REPORTS!!! i downloaded forge 1.8 1577 and sponge spongeforge-1.8-1577-3.0.0-BETA-1000, then i started forge for accepting eula, then i started again and saw that forge is working good without sponge mod… then i put sponge in mods folder and all i get a stupid crash report!!! Also i tried beta-1045 and some other versions too… its the same error!!! im looking for a solution for nearly 3 months i tried forge based server and kcauldron but i need 1.8 so just remove it from ur site or make it work!!!

---- Minecraft Crash Report ----

WARNING: coremods are present:
SpongeCoremod (spongeforge-1.8-1577-3.0.0-BETA-1000.jar)
Contact their authors BEFORE contacting forge

// I’m sorry, Dave.

Time: 11.08.2016 20:46
Description: Exception in server tick loop

net.minecraftforge.fml.common.LoaderException: java.lang.NullPointerException
at net.minecraftforge.fml.common.Loader.identifyMods(Loader.java:339)
at net.minecraftforge.fml.common.Loader.loadMods(Loader.java:483)
at net.minecraftforge.fml.server.FMLServerHandler.beginServerLoading(FMLServerHandler.java:87)
at net.minecraftforge.fml.common.FMLCommonHandler.onServerStart(FMLCommonHandler.java:355)
at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:117)
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:438)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.NullPointerException
at com.google.common.base.Preconditions.checkNotNull(Preconditions.java:213)
at org.spongepowered.common.data.processor.common.AbstractSingleDataProcessor.(AbstractSingleDataProcessor.java:43)
at org.spongepowered.common.data.processor.common.AbstractSingleDataSingleTargetProcessor.(AbstractSingleDataSingleTargetProcessor.java:49)
at org.spongepowered.common.data.processor.common.AbstractEntitySingleDataProcessor.(AbstractEntitySingleDataProcessor.java:38)
at org.spongepowered.common.data.processor.data.entity.ScreamingDataProcessor.(ScreamingDataProcessor.java:44)
at org.spongepowered.common.data.DataRegistrar.setupSerialization(DataRegistrar.java:186)
at org.spongepowered.common.registry.SpongeGameRegistry.preRegistryInit(SpongeGameRegistry.java:142)
at org.spongepowered.mod.SpongeMod.(SpongeMod.java:119)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
at java.lang.reflect.Constructor.newInstance(Unknown Source)
at java.lang.Class.newInstance(Unknown Source)
at net.minecraftforge.fml.common.Loader.identifyMods(Loader.java:334)
… 6 more

A detailed walkthrough of the error, its code path and all known details is as follows:

– System Details –
Minecraft Version: 1.8
Operating System: Windows 10 (x86) version 10.0
Java Version: 1.8.0_101, Oracle Corporation
Java VM Version: Java HotSpot™ Client VM (mixed mode), Oracle Corporation
Memory: 813942472 bytes (776 MB) / 1216348160 bytes (1160 MB) up to 1216348160 bytes (1160 MB)
JVM Flags: 6 total; -Xms1200m -Xmx1200m -XX:+UseParNewGC -XX:+CMSIncrementalPacing -XX:+CMSClassUnloadingEnabled -XX:ParallelGCThreads=2
IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
FML: MCP v9.10 FML v8.0.99.99 Minecraft Forge 3 mods loaded, 0 mods active
States: ‘U’ = Unloaded ‘L’ = Loaded ‘C’ = Constructed ‘H’ = Pre-initialized ‘I’ = Initialized ‘J’ = Post-initialized ‘A’ = Available ‘D’ = Disabled ‘E’ = Errored
mcp{9.05} [Minecraft Coder Pack] (minecraft.jar)
FML{} [Forge Mod Loader] (server.jar)
Forge{} [Minecraft Forge] (server.jar)
Loaded coremods (and transformers):
SpongeCoremod (spongeforge-1.8-1577-3.0.0-BETA-1000.jar)
Profiler Position: N/A (disabled)
Is Modded: Definitely; Server brand changed to ‘fml,forge,SpongeForge’
Type: Dedicated Server (map_server.txt)

ALSO… dont ever tell me that my java version is the problem… i tried java 8u40, 8u71, 8u73, 8u91, 8u92, 8u101, 8u102… none of them worked!!! kcauldron 1.8 would be much better…

1.8 sponge is abandoned for 1.8.9 and 1.10.x

i want gilby’s voice chat mod but its 1.8 and i dont think they are gonna update it… :sob:

Well if the mod you want is abandoned past 1.8 and Sponge isn’t doing support for older builds, then you’re going to have to choose between the two. Not much else to say.


Considering you are using a build over 650 builds old, of course you are going to have issues. Use the LATEST SpongeForge build. You will not receive any help unless you do.