SpongeVanilla Crashing from a zombie

I’ve got an errant zombie crashing the server. At least, that’s what the crash-report log looks like, to me.

Is there a way I can remove the zombie from the game, or kill all entities in the world? When I log into the game, the server crashes almost instantly, so I don’t have a lot of opportunity to run any major commands.

I’m not running any mods or plugins (if there are any). And I’ve got the latest build of SpongeVanilla.

Seeing the actual log would be nice…

Also, “/minecraft:kill @e[type=Zombie]” will kill all the zombies in a world

Perhaps add a crash log so we can possibly fix the issue as it might very well be from our end?

I used to fix such a bug with MCEdit …
There are also “chunkfix”-tools that remove all entities from a world.

I’ve been having the same issue with spongevanilla here is a pastebin of the issue:

Note: I have also seen the same error for skeleton though i can’t find the error log for that.

Thanks everyone, I should have posted the log. Here is the crash-log.

Crash Log

I’ll try that command.

I’ve been having trouble reproducing this. Are there particular conditions under which this happens?

Other than just logging in, that’s about all. I know it happens when I log in, but I’ll check to see if it happens when any other user logs in.

I can upload other logs if you think that would help.

If possible it would be helpful if you would upload the server (including the configuration, the whole folder).

I guess that all mobs are being included in a class. That also contains functions to contain certain arguments that are only available for different mobs. Such as “Entity’s Verhicle” and “Entity’s Rider”, they might only be used for pigs and for horses. When they are not being used they are declared nothing, noppes, nada, null.
It does not know how to handle an unused argument.

Ok. Here’s a link to my server and configs



I’ve just downloaded your server and my first guess is that you tried to upgrade from a Sponge 1.8 version to a Sponge 1.8.9 version and during the upgrading process it didn’t update the libraries and configuration.

Update: Was not the problem.

It is a bit messy :(. But this could not be the problem.

At the first try the world couldn’t be loaded correctly had to remove the file “world” and rename the folder “worldstorage” to world. I added a batch file to start the server, containing: java -jar server.jar

Starting up a Minecraft 1.8.9 using a premium account, added the server. Zombies are working just fine.
No crashes, only the usual messages.

And then I tried the arguments you used to start the server: -Xms1024M -Xmx1024M -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalPacing -XX:+AggressiveOpts (these where all noted as unrecognized by Sponge.)

There where no problems. Zombies where working fine.

I think that there is a problem with OpenJDK, I’ve heard that there are certain versions of OpenJDK specialized for use in a server. They might be optimized but they might not contain certain functions that SpongeVanilla requires. I’m going to test it in a 64 bit Debian Linux virtual environment after dinner.

Installed Ubuntu 14.04 LTS x64 in a virtual machine.
Updated the repository and installed OpenJDK 7 JRE using: “sudo apt-get install openjdk-7-jre”.
Found out that the Ubuntu repositories does not contain OpenJDK 8 JRE.
Had to add another repository eventually I got it installed and my test server worked.
Ran the server, there where no problems.
Ran Minecraft under 1.8.9 on my Windows host and connected with the server with the same premium account. And it worked.

My conclusion is that the server is alright an functional. It could be possible that there is a problem with your host or with your Minecraft client.

This is all I can troubleshoot.

I hope that this can help you out.


Great, thanks a lot for the information. I’ve been using it with Minecraft Server Manager to take backups and snapshots. I have another server running on it so it was taking the default invocation command. I can modify it to remove all the extra items for garbage collection, etc and get it down to the basic java callout.

I was able to reproduce your problem and opened ConcurrentModificationException on EntityAINearestAttackableTarget · Issue #212 · SpongePowered/SpongeVanilla · GitHub, we’ll try to fix it as soon as possible.

Basically this is an issue that will not always happen, likely only if a mob is trying to target a player but there are other entities in the world that are far away. It’s not related to options given to the Java command, you just need a bit of luck to be able to reproduce this problem.

EDIT: I’ve pushed a possible fix for this issue, can you try downloading 1.8.9-3.1.0-BETA-208 from https://repo.spongepowered.org/maven/org/spongepowered/spongevanilla/ and see if that fixes the issue for you?
Note: The problem does generally not always happen so it might also just work fine again for now, however in that case we can still investigate again later.

1 Like