Struggling to build Griefdefender

As the title suggests I have been struggling to build Griefdefender, for two days.

I have looked all over the place for solutions and keep coming up empty handed and would like some help. I’ve downloaded gradle 4.10.3, I’ve installed JDK 1.8, I’ve even built forge 2860 just trying to follow what people have said to do along with just running the gradle build. Right now the error I get when building it is "Could not determine the dependencies of task ‘:bukkit:compileJava’.

Could not resolve all task dependencies for configuration ‘:bukkit:compileClasspath’.
Could not resolve project :GriefDefenderAPI.
Required by:
project :bukkit
Unable to find a matching configuration of project :GriefDefenderAPI:
- None of the consumable configurations have attributes."

I’m not sure what I need to do in order to resolve this issue. Some hand holding would be greatly appreciated.

I get round this issue by deleting the Bukkit folder

Therefore it doesn’t try to build the Bukkit edition

But it looks like you have downloaded the implementation of grief defender but not also the API.

Check the API folder, if it’s blank then download the api

Okay I did that and now I’m only more lost. It’s complaining that it needs Gradle 7.0+ What version of Gradle should this all be using?

To be honest I haven’t build grief defender for a while so cannot remember.

Try 7.0 and then see what it complains at next (I remember it complaining about dependencies last time I built it)

Am I supposed to use the API as the plugin? Any attempts to build the plugins before on 7 always failed from what I remember.

Supposed to build the plugin. The API gets put into the plugin.

Oh what sponge API are you trying to build for? I know grief defender got updated to API 8 reacently. So you maybe accidentally building that

I am trying to build it for 1.12.2, unfortunately I’m unaware what version of griefdefender I have and don’t think I have a version checklist available to use.

If you go into the file gradle.propeties you should see a lot of versions. There should be one labelled commonVersions that will tell you the sponge API and Minecraft version

1.12.2 for Sponge. 7.3

Nice. In that case, try gralde 7. It maybe that it failed due to something on the Bukkit side of things

Alright… It’s strange because the spigot version is 1.16.4. The gradle build batch file also downloads and uses version 5.6.4.

What is the build command your running?

I’ve ran the gradlew.bat file and I’ve used cmd to cd the directory and run gradlew build. Both have resulted in errors.

Try running the command

gradlew build :sponge

And also

graldew build :common

I can’t remember the order in which these should be ran, so if the first fails and the second passes, then try running the first again

This looks fun to dissect. Can’t tell if I need a core plugin here or if I need to be providing a version number somewhere.

The version number shouldn’t matter. But instead it looks like it’s looking for the maven plugin to download dependencies and failing to find it.

I’ve only ever installed gradle and maven together

This is the first time maven is being made important through my searching. Time to go find it I guess.

I’m assuming I do the same thing with it that I have done with gradle.