Struggling to build Griefdefender

Installing it now, any settings I should have? Like create associations?

No need to have anything special

Okay so I have intellij installed and the project imported. Not sure where to go from here.

On the right there should be a tab called “gradle” where you can double click on build

This will probably give the error that you got before. However you can click file > settings > search for gradle and then somewhere you can choose either use gradle wrapper or use specified gradle etc

Click the use your own gradle and then attempt to run build again

Edit:
I should be able to get on my laptop tomorrow so I’ll try to build it myself and document the steps I took

Still throwing out the Plugin [id: ‘maven’] error. "Build file ‘C:\Users\Darkrium\Desktop\GriefDefender\GriefDefender-master\common\build.gradle’ line: 2

Plugin [id: ‘maven’] was not found in any of the following sources:
"

I have just tried building from scatch again on my PC. I got it to build and wrote down what I did step by step. So here you go

How to build

Requirements

Steps

  • Open a terminal (CMD on windows)
  • Navigate to a new folder
  • run git clone --recurse-submodules https://github.com/bloodmc/GriefDefender.git
    cd GriefDefender
  • removed include "bukkit" from settings.gradle file (This file can be opened in notepad)
  • open the sponge folder and create a new folder called libs (case sensitive)
  • Place MCClans inside that libs folder ( Release 1.6 Sponge 1.12.2 API 7 · HexagonMC/mcclans-core-sponge · GitHub )
  • Place PlaceholderAPI inside that libs folder ( rojo8399 / PlaceholderAPI )
  • java -version to ensure Java 8 is the main (depending on your exact version of java, it maybe --version instead → This is to ensure your Java 8 isnt just installed, but the primary Java version)
  • Go back to the terminal and run cd GriefDefenderAPI
  • Then run "gradlew" build
  • Then run cd ..
  • Then run "gradlew" build
  • find compiled jars in ./sponge/build/libs/

Thank you so much. This did in fact work! Where did you find that those libraries were required? Did I just miss something entirely?

When i was building it. I got the error message saying “class Clan could not be found with package X”. So I just googled the package (thinking it would show me a error report of the plugin to wit I could work out the plugin name) however instead, both have GitHub so it made it a lot easier on finding it.

As for your original issue (saying it needs gradle 7). I think you miss interpreted the warning message of “this gradle file contains deprecated lines that will no longer work in gradle 7+”. That’s basically saying it won’t work with gradle 7+ but your current version is fine

Hello, I was following your “How to build” and everything was working smoothly untill i reached the last “gradlew” build in GriefDefender. where i get tons of fails and issues Screenshot - afbe601d5789ec19393ca5206034e159 - Gyazo would you know how to fix this or am i stuck?

Your getting a 503 (http) error when getting the mappings for minecraft. If you want to go technical you could download these manually and then store them in the .m2 folder however this can get technical

The too technical didn’t read. Just need to wait for the server to come back so your able to download it

It looks like the website is back up and running so have another go

Im still getting a 503 when i try. Also getting the error below on the second to last step.

A problem occurred evaluating settings 'GriefDefender'.
> Could not get unknown property 'serootProject' for settings 'GriefDefender' of type org.gradle.initialization.DefaultSettings.

I removed the first line in the setings.gradle and that worked but not sure if correct. Then I got the 503.

@MoseMister

Once i get back on my pc ill take a look. Maybe that grief defender has changed so my instructions maybe out of date.

Ill also see if i can get round the 503 error

Ye, the website still is unreachable it says

So just tried it myself and it works fine using those steps.

Turns out thats not the website it should be getting it from (thats only for worldedit code) however its trying to get it from that website because its just trying all the possible sites it knows.

Shouldn’t make a difference but I did run all my gradle code in the program called Intellij (a program to build java programs)

So any idea what i might be doing wrong then?? i tried running it trough Intellij and got the same error towards the end. My gradle version is 7.5.1 if that can affect it

It should be 5.6.4. if you used gradlew it should be that version. However if you used gradle then it will use your version of gradle installed

i used gradlew to build, will it matter if i use jre instead of jdk?

As long as %JAVA_HOME% is set as java 8 it doesn’t matter. As for JDK vs JRE. JDK (Java development kit) is needed to build

my java -version says im using SE Runtime Enviroment, would that explain why im getting an error on the second gradlew? even tough i cleared the first one with no problems?