The naturalRegeneration of gamerule turn to false

I asked others, they said it was sponge’s question, do you have this kind of situation? How to solve it

I don’t understand the question, but with Bukkit/Sponge due to the multiple dimensions you may need to set the gamerule in all loaded worlds else players might be able to regenerate inside the nether or end.

I mean I set the /gamerule naturalRegeneration true after, restart the server, this setting will change back to false.
My English is not good, I am sorry

I am unable to reproduce this error in my single player dev environment version: (dca378ef1ab1a74a5186c89039eb68dc6eab2f95 [dca378e] 36 behind master), what version of SpongeForge / SpongeVanilla are you using, single player or dedicated server?

dedicated server

I’m also unable to reproduce this on c49c920897ece2657a0f53f67c74609c5b4ee204 [c49c920] Which is one of the 1.8.9 builds.

Will try a dedicated server next.

Unable to reproduce on a dedicated server in dev environment.

I hope this means that the bug is fixed, as opposed to only occurring in production / only on your particular world.

If you can I’d try upgrading to the latest 1.8.9 builds of sponge and forge, and see if you can reproduce the problem.

If you can’t upgrade at this time, try making a new world and see if the problem persists, if creating a new world fixes it, you should be able to fix it by setting the gamerules.

All game rules are saved in the same way (stored in level.dat) so it shouldn’t be just one rule that’s not working.
@bunSakurAing Can you confirm this still happens when using the latest SpongeForge? spongeforge