Trouble Getting Sponge 1.7.10 to run

I’m running a modded 1.7.10 server, due to the fact that the majority of Forge mods have not been updated to 1.8. I downloaded the only Sponge build for 1.7.10 (sponge-1.7.10-, and an appropriate Forge of a higher build number still under the 1.7.10 category (forge-1.7.10-, and when I run my server it says Sponge is a non-mod jar and it’s injecting it in to the class path.

After that my server runs fine, however Sponge appears to not be running. I type /sponge and it says invalid command, and no plugins work.

Any ideas what I could be doing wrong?

Awww. I have to mention. The 1.7.10 build of sponge is old and unusable :frowning:. You could try to modify the minecraft version in the build.gradle and build it. But I can’t guarantee that it will work.

Wouldn’t building from the newer git still have issues, given that it’s looking for a more recent version of Forge? The latest I can use while on 1.7.10 is Forge

If I were to change the forge version in the build.gradle as well, do you think that would work? Or are there other dependencies within the mod itself that would break?

1.7.10 sponge is old to the point where no plugins will even work on it. The API is incompatible.

Changing the current forge version manually will crash and burn.

I’d wait until whatever mod you have that requires 1.7.10 updates to 1.8 honestly.


Ehm, that won’t happen. Most mods are waiting on 1.9. They want stability in the render system that has changed in 1.8.

Yes it would. This is why Sponge runs on Forge 1.14.x.xxxx only. The currently recommended build is 1371 with the newest Sponge Version on MC1.8 :wink:

No Sponge for you if you’re running MC1.7.10. Sorry :frowning:

Precisely, the majority of mods are waiting to update because 1.8 introduced a lot of instabilities. I’m running a Tekkit server that I manually updated to 1.7.10, so I have about 96 mods on my server, and probably about 80 of them are only on 1.7.10.

I guess I can try old Cauldron again, the main reason I hesitated with Cauldron was that I got a bunch of warning messages in the console stating that Cauldron could cause incompatibilities with a lot of the mods.

Couldron is your best option as Sponge just won’t run with 1.7.10. Or you have to wait for 1.9 (as Sponge and Forge will update) and hope that mod developers will update from 1.7 directly to 1.9 because they skipped 1.8.

Only reason a sponge build for 1.7.10 exists is that forge wasn’t updated for 1.8 back then.
Sponge was never planned to be compatible with 1.7.10.

Well they were thinking about it at some point.