Trouble Getting SpongeForge to work in a third-party server

Hello to those who are interested!

I cannot for the life for me get SpongeForge working on my VeryGames server. I have already done the following;

  1. Downloaded and installed through the GUI the Forge and SpongeForge 1691 server build.
  2. Started up the .jar files to get all of the remaining configs etc.
  3. Moved the contents of the install folder over to the FTP, replacing my other server profiles

Also, YES I have the up to date JRE and JDK, Minecraft version, and the SpongeForge version match the Forge version, and they all all on 1.8.9.

I would have loved Sponge by now if it even started in the first place. I start up the server, type /sponge help, and all I get is the unknown command error.

I would like to know what I am doing wrong here, or if it is even possible to run SpongeForge on a service such as this; do I really need a dedicated server based off of my machine or go through a third party method.

Swift responses are appreciated, since I have an anxious community waiting to hear back from me on this issue.

Mind posting the versions of forge spongeforge java plus log of the startup

He actually did post Forge and SpongeForge versions:
SpongeForge 3.1.0-BETA-1046

The SpongeForge version I am using is “spongeforge-1.8.9-1691-3.1.0-BETA-1046”

The Forge version I am using is

The Java Runtime Environment version is JRE 8u74

The Java Development Kit version is JDK 8u74

This is all I get at startup:

Sun Feb 7 17:20:24 EST 2016 - Server is starting now!

[17:20:27] [Server thread/INFO]: Starting minecraft server version 1.8.8
[17:20:27] [Server thread/INFO]: Loading properties
[17:20:27] [Server thread/INFO]: Default game type: ADVENTURE
[17:20:27] [Server thread/INFO]: Generating keypair
[17:20:27] [Server thread/INFO]: Starting Minecraft server on *:25565
[17:20:28] [Server thread/INFO]: Using epoll channel type
[17:20:28] [Server thread/INFO]: Preparing level “Tutorial”
[17:20:28] [Server thread/INFO]: Preparing start region for level 0
[17:20:29] [Server thread/INFO]: Preparing spawn area: 88%
[17:20:29] [Server thread/INFO]: Done (1.285s)! For help, type “help” or “?”
[17:20:29] [Server thread/INFO]: Starting GS4 status listener
[17:20:29] [Query Listener #1/INFO]: Query running on

That seems to me like forge isn’t starting up - are you running the forge jar or minecraft jar when you start the server?

The provider has it so I essentially flick a switch to turn on the server. It does not give me the option to execute a specific .jar; is there a way to set this up in the, since launch or batch file alone do not seem to work either?

Can you provide start script?

The Launch script is as follows:

java -Xms1G -Xmx2G -jar forge-1.8.9-1691-3.1.0-BETA-1046.jar

Try update to:


we have a stable server running on this build

1 Like

When downloading SpongeForge you can see the version of forge that they are running as well. Beside the build version og sponge and i just noticed @Thorns_Ofire we need to change our forge version
But like he said ours is running pretty good! :slight_smile:

That’s not a name of a forge file. Looks like you merged the names of the two jars. And either way, your log shows it starting minecraft_server.jar

1 Like

So here is an update regarding my problem:

SpongeForge has been updated to spongeforge-1.8.9-1732-3.1.0-BETA-1141.

Forge has been updated to forge-1.8.9-

Java JDK and JRE are both 8u74 still.

The launch script is as follows:
java -Xms1G -Xmx2G -jar forge-1.8.9-

The server starts up fine, loads everything just fine when I booted from my own machine. I upload the server files as they are, replacing the ones that are on the server, and they STILL will not boot.

I also cannot find a method from my provider that allows running a specific .jar. Any help on this especially would be great!

The only thing I can think of is putting the bat file into the plugins folder.

I think I know why…

You have windows on local machine the server has linux so the bat file is not read instead the .sh file is read check that out via FTP.

The .bat file does not work using the method I tried, so I am out of options.

As far as converting to .sh, I have confirmed with the provider that their OS for their servers are windows based. I also cannot create a .sh file to begin with; it just comes out as

The fact that the server jar is started directly, despite the fact that you have a script in place, makes me thing that the server provider is simply starting “minecraft_server.jar” rather than running a given script.

Can you confirm with the server provider that the script you wrote is actually being called? (you could also add an “ECHO” to the batch to prove that it’s not being run directly)

I have figured out how finally!

The provider was in French, so I had to use Google Translate to figure out that I had to use their Minecraft OpenMod option in order to select the .jar!

Thank you all for your help!

1 Like

Glad you solved it :slight_smile: