Unable to start server with sponge


#1

I’m currently trying to setup a server with FTBUltimateReloadedServer 1.5.0.
I’ve installed Sponge Forge 1.12.2-2768-7.1.5
With Forge 1.12.2-14.23.5.2815-universal.
I’ve tried to start the server with Java 11 or 8. Both either worked.

Here is the logs of the start up.
https://hastebin.com/ocusimerid.md


#2

I suspect it’s actually FoamFix setings causing the issue. The fix is detailed here.
Also, stick to Java 8, neither Forge nor Sponge are updated to use Java 9+ at present.


#3

Thanks. It worked, but it has lots of errors comparing that I don’t install SpongeForge.

Here is the logs: https://hastebin.com/hilomonalo.sql


#4

Im not seeing any errors saying that you shouldnt install sponge at all. All im seeing in terms of sponge is it correcting commands from other mods. Im also seeing a lot of mods crashing due to JSON Syntax exceptions, mods attempting to register new blocks with the key of minecraft (which should never occur), more then a few client side only mods attempting to load


#5

I didn’t say I shouldn’t install sponge. I can run sponge and I can join the server with the plugins running. But I don’t know did some mod crash as if you search “error”. There’s some.