VirtualChest - Provide virtual chest GUIs for menus like ChestCommands (SpongeForge/SpongeVanilla 1.10.2, 1.11.2, and 1.12.2)

Ohai that’s great. :grinning:

Hey man! You have really simple dupe… Mods like: MouseTweaker, InventoryTweaks etc, can steal items from menu, so result of this - simple items dupe.

What spongeforge version are you on?


I can take out the item…

1 Like

Definitely something that needs to get checked, possible that it could be something with sponge.

For now I suggest using a mod banner in order to prevent users with inventory sorting plugins from obtaining the items. At least until zzzz can figure out what the problem is and updates the plugin.

It broke it the latest versions of sponge. It can’t be reproduced in 2259

Oh, no…
This sponge version has inventory fix. I need it.
It turns out that the following versions of a sponge have this fix too, so the plugin will be with a bug further. By the way, now secondary and primary clicks for unknown reason don’t work. I will better refuse a plugin in favour of updates of a sponge.

Ok, fixed. @Lefty @SnowBlitzz @tridaak @LC_Games
Try the latest version (v0.3.1) now.

The reason is that Sponge has inconsistent implementation of higher versions. A slot has a parent. In the older version of sponge, inventories are grouped and the parent of the slot is only the red rectangle as shown below: while the parent of the slot is the whole inventory in the higher version. That causes the inconsistency.

Thanks for fix :slight_smile: Will test it out later.

Yes thank you :slight_smile:

Good day ZZZZ
i seem to have a issue when i am using your plugin people are able to put items into the GUI itself and then when they click it they lose there items.

@xskymaster, You must install latest version of VC and Sponge.

I’ve been able to replicate this issue with latest SpongeForge and VC.

I tried the latest version of Forge(2281) and SpongeForge(5.2.0-BETA-2292), while I didn’t reproduce the bug successfully. Could you give me some more information about the versions of your server?

Can we use this plugin as a sort of global market type plugin or is this different

To reproduce the bug, make sure you have empty slots in the virtual chest. Then put an item in the empty slot. Gonna update my sponge version and test it out again to see if the problem’s still there, if so, Ill send a list of all the plugins I have Order is backwards, don’t have screen capture software to make a clip.

├── Nucleus-0.28.1-1.10.2-S5.1-plugin.jar
├── PixelExtras-1.10.2-2.2.5-universal.jar
├── Pixelmon-1.10.2-5.0.3-universal.jar
├── PixelmonEconomyBridge-1.10.2-1.3.0.jar
├── spongeforge-1.10.2-2281-5.2.0-BETA-2300.jar
├── TabManager-1.0.4.jar
├── TrainerCommands-1.10.2-2.1.5-universal.jar
├── VirtualChest-0.3.2.jar
└── worldedit-forge-mc1.10.2-6.1.4-dist.jar

These are all the mods I have, using latest version of VC, Forge, and SF.

Well, I reproduce the bug successfully, and that’s my fault.
Please try v0.3.3 now.


Tried it, it works perfectly. Thank you :slight_smile:

1 Like