WE and SpongeForge

So, at this point, it is getting too hard to actually use the plugin without coming into this issue, that spams the console for a solid 5 minutes and makes everyone disconnect.

I am running:
worldedit-forge-mc1.10-6.1.4-SNAPSHOT-dist.jar spongeforge-1.10.2-2052-5.0.0-BETA-1675.jar forge-1.10.2- Polis-1.10.2-2.6.8.jar

If anyone understands what is going on, you are very, very welcome. WorldEdit support has been of no help, since this is a sponge issue - and at this point, I have seen the error across sf versions, meaning this isn’t just one version’s problem.

EDIT: Seems to only happen when water and lava are involved.

Have you tried using WorldEdit for Sponge? You’re using the Forge version above.

Shouldn’t it work though? SpongeForge allows for both sources of plugins. I have thought about it, but rather unsure at its stability. And with a custom map, can’t really allow for WE mess ups.

Yeah, the Forge version should work fine… but as it apparently doesn’t, from what you posted above, then I’d try the alternative (on a backup map if needed) to see if it gives the same issue. It’s been stable for me, although I haven’t tried turning any worlds inside-out lately…

1 Like

haha, and I do do my fair share of world fiddling, that’s why I am unsure about moving into Sponge’s WE - especially since this is 1.10.2 sf.

I do have to ask, isn’t this a spongeforge issue? Because from what I can tell, it is sponge that is causing the exception in block tracking, so it’s probably a bug somewhere; especially going from the first lines of the error log. Moving plugins because of a sponge bug would be an unfortunate way to deal when a necessary plugin like ForgeWE is giving sponge errors.

I’d be happy to report this if it needs to go to a tracker somewhere, just unsure where would I find said tracker. :smile:

OK, it looks like Sponge can’t find the block changes caused by WE.
Try reporting the issue here: Issues · SpongePowered/SpongeForge · GitHub and see what they make of it.

1 Like