Why does minecraft crash with a R9 290X?

Hi. I recently upgraded from a GTX 560 Ti to a R9 290x. I can play battlefield 4 on ultra, but minecraft crashes whenever I switch to another program and reswitch back to it. Also, I’m getting really lower FPS with this GPU than I was getting with the previous one, and it drops bellow 30 on certain places.
I know this forum isn’t really a help forum, but I mean, Sponge has a great community and a place to ask for help would be great on here.

Just gonna ask the typical questions first, then more specific ones afterwards.

  1. Are your graphics drivers all up to date?
  2. What OS are you using?
  3. If it gives you a crash message, could you put it on Pastebin?
  4. Is your Minecraft modded, or are you vanilla?
  5. What Minecraft version are you running when you experience this?

The 290X is, by far, a better card than the 560Ti, simply because it’s a high end card, whereas the other is an older mid-high-end card.

As for the fps issues, amd has historically been relatively bad with OpenGL and performance. I know this from personal experience as I had one in my previous computer, and never really got very good performance with it.

Minecraft doesn’t actually crash, it just stops working. With or without mods, in any version (I guess, I’ve tried in 1.7.2 and 1.7.5). I’ve replaced the .minecraft already, it keeps “crashing”. I’m using Windows 8.1 Pro, and the drivers are up to date, I’ve checked multiple times.

So this is the only program that won’t work?


What is your Java Version?
Is Java up to date?

Also is it 32 bit java or 64 bit java? This game would be more stable with a 64 bit java.

I have both 32 and 64bit Java, all up to date. The game works, it just stops working.

You have to different bit versions on one computer? I don’t think you’re supposed to…

Google chrome uses 32bit and minecraft uses 64bit. I don’t think creating these problems makes sense, eveything worked as it should before upgrading to the r9 290x. I did not change anything but the GPU itself.

When you have both versions on the same system one can take precedence over the other, sometimes that can be the 32 bit version of java, if that is the case then you have to explicitly set which version of java to use through a shortcut.

You can create a shortcut with this to start the launcher with the 64 bit java.
“C:\Program Files\Java\jre7\bin\javaw.exe” -jar “Path to launcher jar”

Java is not the problem. It worked before, on my GTX 560 ti.

Is OpenGL up to date?

How do you update that? And as I said before, why would it now work when if worked before, on the other GPU?

Maybe ask Radeon Customer Support then.

You, can’t really “update” Opengl, it’s tied to the drivers, it would be better to ask if the drivers are up to date.

I’ve already said that the drivers are up to date. I also reinstalled them twice.

There’s not a whole lot we can do here, it may be a bug in the amd gfx drivers. OpenGL is handled quite a bit differently between AMD and Nvidia, AMD’s implementation of OpenGL tends to be a bit buggier than Nvidia’s, from personal experience, I’ve had an AMD card before and have had problems in OpenGL games with it, from low performance to bsod’s.