World Protection for Sponge?


#1

Hello Sponge community!

I’m brand new to SpongeForge and I’ve never used it before. I’ve got it up and running (pretty sure) but I need help finding a WorldGuard Sponge plugin or something with similar conditions. I’ve found lots of land claim plugins but each one I’ve tried doesn’t have what I need. The biggest flags that I require are fire spread, leaf decay, and block breaking. My server has experienced wild fires and a lot of my builds involve leaves which start to immediately disappear causing lots of lag from saplings and apples and also ruining my build. Most importantly, my future players cannot break blocks of my landmarks and towns.

Relatively, I also need a Grief Prevention plugin like Precious Stones (using silk touch ores that represent a #x# land claim or a golden shovel. Either one will suffice.

Since I’m new, I’m just having trouble finding my whereabouts. If anyone can show me where to find plugins like these, it would help me greatly!

I’m using SpongeForge version 1.10.2-2477-5.2.0-BETA-2698.

Thanks in advance!
Coolkc456


#2

The Sponge version of GriefPrevention, along with Vanilla gamerules should do exactly what you want

/gamerule doFireTick false will stop your fire from spreading (and going out)


#3

I’m using the latest build of SpongeForge but I get the error "[Server] Server thread/ERROR [griefprevention]: Unable to initialize plugin. Detected SpongeForge build 1902 but GriefPrevention requires build 2637+."
Also, is there a Sponge version of WorldGuard that have a variety of flags like WorldGuard?


#4

No, there’s no Sponge version of WorldGuard, and probably never will be (It uses wayyy too much of the bukkit API to be ported sanely). FoxGuard does similar stuff, although there’s no 1.12.2 builds ready yet.

As for GriefPrevention, please make sure you get the right build for the Sponge Version you’re using. Either update SpongeForge, or downgrade GP to an older build. GP is actively maintained.


#5

I’m not sure which version of GP I’m supposed to use. I’m using the latest build of GP for 1.10.2 (version 4.0.1.481) with SpongeForge version 1.10.2-2477-5.2.0-BETA-2698. It’s the latest versions of 1.10.2 for both. The error says it detected build 1902 but that’s impossible because my build is 2698.

You can even see the versions in my mods folder: http://prntscr.com/h1o883


#6

Hello,
You are using SpongeForge 1.10.2 with API 6.0.0, this can be the problem, because I think, GP for 1.10.2 is for API 5.x.x.


#7

The format of the filename is spongeforge-{MCVersion}-{ForgeVersion}-{SpongeAPIVersion}-{SpongeBuildId}

https://docs.spongepowered.org/stable/en/server/getting-started/implementations/spongeforge.html?highlight=spongebuildid

Your Sponge build id is 1902.

According to Ore, the last (released) version of GP for 1.10 is 1.10.2-4.0.1.472
https://ore.spongepowered.org/blood/GriefPrevention/versions/1.10.2-4.0.1.472

The forge repository appears to be somewhat ahead, here are the changes between the version released on Ore, and the forge version you list.

http://files.minecraftforge.net/maven/me/ryanhamshire/griefprevention/1.10.2-4.0.1.481/griefprevention-1.10.2-4.0.1.481-changelog.txt

Build 481:
	bloodshot: Fix subject NPE during debug. Fixes #491
	bloodshot: Save claim data for Trust API calls. Fixes #490

Build 480:
	bloodshot: Save claim data for Trust API calls. Fixes #490

Build 479:
	bloodshot: Fix subject NPE during debug. Fixes #491

Build 478:
	bloodshot: Fix API resize and trust removal. Fixes #484, Fixes #486

Build 477:
	bloodshot: Fix API resize and trust removal. Fixes #484, Fixes #486

Build 476:
	bloodshot: Fix API resize and trust removal. Fixes #484, Fixes #486

Build 475:
	bloodshot: Load PlayerData from storage when called from API. Fixes #483

Build 474:
	bloodshot: Load PlayerData from storage when called from API. Fixes #483

Build 473:
	bloodshot: Load PlayerData from storage when called from API. Fixes #483

You can find the latest stable version of Sponge for 1.10 (1.10.2-2477-5.2.0-BETA-2698) here:

https://www.spongepowered.org/downloads/spongeforge/stable/1.10.2

Sponge for 1.10.2 has been ‘stable’ for over a year now. thus, looking at the latest ‘experimental’ version shows the API branch for 6.0.0 which wasn’t very developed before changing to 1.11 and was never promoted to stable.

We should probably add some sort of warning when stable is newer then experimental for a given version.


#9