WorldEdit for SpongeAPI


#42

Does the //brush command for WE not work in version 1.10.2? We recieve an unknown command error in game.


#43

Version 6.1.5 latest at now.


#44

Also, the range for world edit is very low. Is there a reason for that? When placing or destroying blocks its range is fine but when using /brush or the masking tool, it has the range of the minecraft sword to say the least.


#45

Well, I always brush with a range of 16 chunks without any trouble.


#46

Strange, I wonder why it has no range for me


#47

@kenzierocks
worldedit-forge-mc1.11-6.1.5-SNAPSHOT-dist.jar Build #3647

http://pastebin.com/yJSUnvqG


#48

It mentions the “server watchdog” in there. The watchdog will stop the server if the server takes too long to do something. Were you doing a large WorldEdit change when it crashed?


#49

Yes, I’m making a big change.
//schematic load
//paste
He did not put a single block.


#50

Then that would be why. You can turn off the watchdog by increasing max-tick-time (measured in milliseconds, or thousandths of a seconds) in server.properties.


#51

max-tick-time=60000

On API5 1.10.x he coped with this task.


#52

If you’re using WorldEdit for Forge (it looks like you are), you can also try adding FastAsyncWorldEdit. Note that it does require WorldEdit itself to be installed.


#53

max-tick-time=120000 Inserted the schema. But in the console there were many errors. Thank you!


#54

For now, please use this build with 1.11

http://builds.enginehub.org/job/worldedit/9521


#55

Superficially tested, working.

forge-1.11-13.19.0.2178-universal.jar
spongeforge-1.11-2178-6.0.0-BETA-1988.jar
worldedit-sponge-mc1.11-6.1.5-SNAPSHOT-dist.jar


#56

Good day,

I was looking to try this out, but have a question. In the changelog for worldedit-sponge it mentions implementing Sponge API 5 changes, but shouldn’t that have to be API 6 if it is being built on the 1.11 version?
Just curious if it’s safe to assume that if it is implementing 1.11 that it is also matches the API (6.0)? I may not have any clue what I am talking about. Apologies.


#57

i tried the download link for 1.10 but the server crashes every time i have tried, does it not work for spongeAPI 5.0.0?


#58

forge-1.11.2-13.20.0.2201-universal.jar
spongeforge-1.11.2-2201-6.0.0-BETA-2012.jar
worldedit-sponge-mc1.11-6.1.5-SNAPSHOT-dist.jar (#3629)

http://pastebin.com/NhfUiCnP

Edit: #3663 it seems to work
Edit2: #3663 http://pastebin.com/1SukyN7A


#59

Using the latest release and trying to post a schematic, I get an error however the schematic pastes in with the exception of a few blocks here and there…

http://pastebin.com/PpWNmFkj


#60

1.11 now has an API 6 snapshot.


Sponge /Wordedit question
#61

Using latest dev builds of SpongeVanilla and WorldEdit. Worldedit not loading. Tried a couple combinations of slightly earlier builds to same thing.

http://pastebin.com/TPtNptH1