[1.0.0] LinkClicker ~ Clickable links in chat!

#LinkClicker ~ Clickable links in chat!

##Table of Contents

  • About
  • How To Use
  • Planned Features
  • GitHub
  • Download

Today I was on @Joe_Schmo2840’s brilliant test server, and I was trying to send him some links. BUT HE COULDN"T CLICK THEM DIRECTLY! That’s how this plugin came around.

##How To Use:

  1. Make sure you have a Forge server with Sponge installed, or have a SpongeVanilla server already setup.
  2. Download LinkClicker in the download section of this thread.
  3. Put LinkClicker in the mods folder that is in your server’s directory.
  4. Restart/Start your server.
  5. Give players that you want to be able to click links the permission “linkclicker.use” without quotes.
  6. Enjoy your chat-clickable links!

I’ve also made a simple video showing it off:

##Planned Features:

  • Specific links blacklist
  • TLDs blacklist

You may view the source code here.

Current Version: 1.0.1

  1. Please add https:// support
  2. If I read correctly, everyone can click links. It’s just so that only the links of those with the linkclicker.use permission will be made clickable. Thats a bit unclear from your description.

This is default minecraft behavoir right? I thought I used this before

EDIT: Tested this on my bukkit server (I don’t have a sponge server at the moment) and it works for me

Its a 1.8 issue. Seems to be fixed in later 1.8.x releases. Or by @DotDash :smiley: Installing this now.

Doesnt seem to be working on the server still. Im guessing there is a config somewhere I need to enable.

#Version 1.0.1 is out!

1.0.1 fixed it. Links now work. Thanks again!

That’s because I wrote code for the 1.7 release that turned pasted links into clickable links.


Doesn’t seem to be working on joes server atm, did something break or get disabled?

Is this still a TODO? If so, This might help:


I don’t understand what you mean, only links starting with http:// and https:// are clickable.

Is the plugin still in development? I tried the plugin but it fails to load…

I’ll give it a quick update :wink:

Does this still work?

Can this get an update please? :stuck_out_tongue: