A Problem With SpongeForge!

Hey guys, I’m running a forge server and i’m using spongeforge. Well I put spongeforge in my mods folder located in my .minecraft folder along with some sponge plugins and then i start the server up and go to my server, but for some reason when i type in “/help” it gives me my default op commands, but none of the plugin’s commands. So i signed out of my server and tried playing SP and the plugin’s commands show up when i type “/help”. I later noticed that when i had started my server with the plugins in my mods folder, my server’s folder created a mods folder inside it. So i tried cut and paste the plugins into that mods folder and then when i restarted everything, i went to my server and they still don’t show up. So i went to SP and it doesn’t show up there either! So what’s wrong with it? I’m also running 1.8.9 minecraft and spongeforge

Having a bit of trouble following your logic here so I’ll do my best to help.

First, if you are running a server, you need not do anything with your SP client. You can connect to a SpongeForge server on a Vanilla client. You only need to add Forge to your client if your planning on adding Forge mods to the server.

Second, make sure the SpongeForge jar is in the mods folder on your forge server. To test whether SpongeForge is actually loading try the command /sponge. If it’s not working you may have downloaded the wrong jar. Follow link here to resolve spongeforge

Third, make sure you are using the correct version and build of Forge, for example
spongeforge-1.8.9-1808-4.1.0-BETA-1271 requires forge-1.8.9-, as you can see SpongeForge versioning includes 1808 which correlates with the forge build

Hopefully this helps a bit.

Also its always a good idea to read through this https://docs.spongepowered.org/master/en/server/index.html

Usually you have a server folder which has a mods folder and the server.jar inside it. Now place SpongeForge and all Sponge plugins inside the mods folder, that’s it.

Now start the server like a regular Forge server (start forge-1.8.9-XYZ-universal.jar where XYZ is the version). That’s it!

DONT start the minecraft_server.jar or the SpongeForge.jar. That won’t work.

Let me try to reword this a bit better. Ok i have a folder called “.minecraft” in my appdata which is minecraft’s directory. I took the spongeforge.jar and placed it in the mods folder located in the .minecraft folder along with the sponge plugins i wanted on it. I start minecraft up and then my server. I log into my server and i typed “/help” and all it gave me was the default commands for opped players. I went into my singleplayer world and typed “/help” and all the plugin’s commands showed up.

(Sorry for the second post) As for what Tzk said, I did try putting the spongeforge and plugins into the mods folder located in my server folder which is located on my desktop and its not giving me anything for neither multiplayer or singleplayer

try using this Dropbox - Sponge + Forge - Simplify your life

also all u need is the mods like pixelmon all other mods wich u downloaded from this forum are server side files remove all the stuff u downloaded from here out off your .minecraft>mods folder after placing all the files you downloaded from this forum into the mods folder from the server itself

after that restart both your client & server join it type /help and the commands should pop up :wink:

Ok and how exactly can you even get that version of forge?

press http://files.minecraftforge.net/ Show all downloads enjoy all forge versions for 1.8.9

All right, here’s what you probably need cleared up: DO NOT put SpongeForge, or any Sponge plugins, in .minecraft/mods. Put them in the mods folder on your Minecraft server.

1 Like

JBYoshi, why can’t anyone be so specific as you were just now? That really helped me understand that part so i thank you with the up-most passion in my heart!

1 Like

… We all almost gave the same anwser… We just did put it in a different format how could you know what he means when he’s saying the same thing as the op posts and you dont know what they mean? explain pls?

cause they didnt say “Don’t put it in the .minecraft/mods. instead put it in the mods folder on your server’s directory.” Using words and technical terms or whatever doesnt help me due to my slow brain processing. But dont get me wrong, i’m not dissing you guys cause ik you guys were just trying to help.

Well… technically you can run SpongeForge on the client (in singleplayer). So it depends on what you’re trying to achieve :wink:

But yes, usually you want to run a vanilla client (= no mods) and just mod the server. To achieve this, you setup a forge server and put SpongeForge + plugins into the servers /mods/ folder.

they still aren’t working!!:sob:

wait are you telling me that you cant run plugins and mods simultaneously on a server? only in SP? And what in blazes is a vanilla client?

Yes if you are using SpongeForge, you can run forge mods and Sponge plugins simultaneously. Vanilla client refers to an unmodified or stock version of single player Minecraft

then why wont they work? Here is what i have:

  • AminShop-1.7c.jar
  • BLWarps-2.0.0.jar
  • cfmce-1.0.1-mc1.8.9.jar
  • EssentialsCmds-8.0.7.jar
  • FedorasEconomy-1.0.jar
  • FoxCore-0.8.1-108-server.jar
  • FoxGuard-0.18.0-249.jar
  • Keys-1.2.jar
  • PermissionsEx-sponge.jar
  • projectworlds-4.1.0-0.9.0.jar
  • spongeforge-1.8.9-1808-4.1.0-BETA-1271.jar
    I’m running forge forge-1.8.9-
    and my client(Which is the one that you get when clicking on minecraft.exe from minecraft.net) is version 1.6.61

Are these mods on client or on the server?
If on the server: is the client modded?

What happens when you type /sponge version into the servers console?

How are you launching the server? What’s in the start up script? I’m referring to the .bat file assuming you’re running Windows

1 Like

I don’t know. All I know is that these mods are in my “C:\Users\Richard\Desktop\Wasteland Overhaul Server\mods” and they do not even work even after typing /sponge to see if its loading. Then i tried to put them in my “.minecraft\mods” and i get an error saying that “foxcore:any” couldn’t be found and to check my logs and my logs says this: http://pastebin.com/8AQ7TKQs