⚛ Nexus v1.8.5b - Providing 100+ Essential Commands and Features


#81

Youre using the wrong version of SpongeForge. You need this

http://files.minecraftforge.net/maven/org/spongepowered/spongeforge/index_1.9.4.html


#82

Thank you TrenTech.

I have downloaded the jar file and put it in the servers mods folder.

But it still seems the plugin is still not working. None of the commands for it work :frowning:

I have gone and removed everything and started from scratch but still no luck. I will have to get some sleep and make a fresh start at it in the morning.

Thank You

EDIT:

Its not just this plug in thats not working, no others will work either.. Must of borked something! But I cant see what :frowning:


#83

@nettyneets

The problem is that /say currently is not an alias of /broadcast but I'll fix that within the next version :slight_smile: What goes for the url-permission thingy I like the idea as well as having the opportunity to list other players homes! :wink:

@Nagasaki

I'd recommend that you try SpongeForge 1402 in combination with Nexus v1.8.4a as this is whats Iam currently using. :slight_smile:


#84

Thanks,

I think I see why I am having issues.

I am using MC 1.9.4 but your mod is for 1.8.9 and I am running 1.9.4 and thus it will not work unless I downgrade. And this plugin uses API Version 4.x.x. and I am using 5.x.x


#85

Nexus v1.8.5b has been released:


  • Updated Nexus to be compatible with SpongeForge versions for MC 1.9.4
  • Added /say as an alias for /broadcast

Download it here.

Note: If you're still using MC 1.8.9 you should use Nexus v1.8.4a!


#86

it looks like the permission for colored chat doesnt work, seems everyone has it even if i set it to -1

edit: it only seems to be one person weirdly enough :s


#87

Im getting this error on 1.10.2-5.0.0-BETA-89

[11:27:38] [Server thread/ERROR] [Sponge]: Could not pass MessageChannelEvent$Chat$Impl to Plugin{id=nexus, name=Nexus, version=1.8.5b, source=mods/Nexus.jar}
java.lang.NoClassDefFoundError: org/spongepowered/api/service/permission/option/OptionSubject
at main.java.me.cuebyte.nexus.utils.PermissionsUtils.getPrefix(PermissionsUtils.java:23) ~[PermissionsUtils.class:?]
at main.java.me.cuebyte.nexus.events.EventPlayerChat.onPlayerChat(EventPlayerChat.java:75) ~[EventPlayerChat.class:?]
at org.spongepowered.common.event.listener.ChatListener_EventPlayerChat_onPlayerChat41.handle(Unknown Source) ~[?:?]
at org.spongepowered.common.event.RegisteredListener.handle(RegisteredListener.java:95) ~[RegisteredListener.class:1.10.2-5.0.0-BETA-89]
at org.spongepowered.common.event.SpongeEventManager.post(SpongeEventManager.java:261) [SpongeEventManager.class:1.10.2-5.0.0-BETA-89]
at org.spongepowered.common.event.SpongeEventManager.post(SpongeEventManager.java:274) [SpongeEventManager.class:1.10.2-5.0.0-BETA-89]
at org.spongepowered.common.SpongeImpl.postEvent(SpongeImpl.java:138) [SpongeImpl.class:1.10.2-5.0.0-BETA-89]
at net.minecraft.network.NetHandlerPlayServer.handler$onProcessChatMessage$0(SourceFile:113) [me.class:?]
at net.minecraft.network.NetHandlerPlayServer.func_147354_a(SourceFile:815) [me.class:?]
at net.minecraft.network.play.client.CPacketChatMessage.func_148833_a(SourceFile:37) [im.class:?]
at net.minecraft.network.play.client.CPacketChatMessage.func_148833_a(SourceFile:9) [im.class:?]
at org.spongepowered.common.network.PacketUtil.onProcessPacket(PacketUtil.java:119) [PacketUtil.class:1.10.2-5.0.0-BETA-89]
at net.minecraft.network.PacketThreadUtil$1.redirect$onProcessPacket$0(SourceFile:39) [fl$1.class:?]
at net.minecraft.network.PacketThreadUtil$1.run(SourceFile:13) [fl$1.class:?]
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_91]
at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_91]
at net.minecraft.util.Util.func_181617_a(SourceFile:45) [h.class:?]
at net.minecraft.server.MinecraftServer.func_71190_q(SourceFile:134) [MinecraftServer.class:?]
at net.minecraft.server.dedicated.DedicatedServer.func_71190_q(SourceFile:338) [ld.class:?]
at net.minecraft.server.MinecraftServer.func_71217_p(SourceFile:554) [MinecraftServer.class:?]
at net.minecraft.server.MinecraftServer.run(SourceFile:458) [MinecraftServer.class:?]
at java.lang.Thread.run(Thread.java:745) [?:1.8.0_91]
Caused by: java.lang.ClassNotFoundException: org.spongepowered.api.service.permission.option.OptionSubject
at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:191) ~[launchwrapper-1.12.jar:?]
at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[?:1.8.0_91]
at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:1.8.0_91]
... 22 more


#88

I am having the same issue


#89

im having an issue with feed not filling my saturation level and also im using journeymap and when I set a way point I can't use it to teleport
says:Usage /tp [target]

/tp is not working


#90

#91

Can commands be use with command block?
Expample:
Command block code: /nexus:spawn SpawnName


#92

I don't think that specific command would, even if Nexus commands did work with command blocks.
Since it's hard coded to only teleport the one that used it.


#93

im using a few plugin
but the only one that i have issues with is nexus and essentialcmds
none of the commands work

but some of the features of nexus work such as the chat prefix's as i can see righ off hand
so i downloaded another plugin as a temp so i can set my homes and world spawn

any idea why none of my commands would work

i am using pex as my permission plugin but the commands dont work with or without it


#94

Is there a way to Blacklist item(s) so that a player with the nexus.item permission can't spawn certain items in (like commandblocks?)


#95

command block -> tppos @P 20 20 20 -> Player not fount!
what problem?


#96

I believe it's case sensitive. Try @p instead


#97

Still the same
This is same EssentialCmds


#98

I think the @ args are specific to vanilla commands, meaning they're processed by the Vanilla command executers, not the Command block itself. Most likely the Nexus and EssentialCMDs commands do not handle these arguments so they are not working as expected.


#99

Although it is possible , but as you @p [type = player]. But only ttyae be alone on the server is used.


#100

Hello, thanks for making this plugin, it's really useful. It would be perfect if you added one command, /invsee. If you can do this, that would be great! Thanks