"could not find the main class GradleStart"

If i try to launch my client in eclipse this error popsup idk what to do

Mind showing your build.gralde file

Also what sponge api are you targetting?

Also a log of the gradle build would be good too

buildscript {
repositories {
jcenter()
maven {
name = ‘lukflug’
url = ‘Maven repo - lukflug's website
}
maven {
name = ‘SpongePowered’
url = ‘Repository - Nexus Repository Manager
}
}
dependencies {
classpath ‘net.minecraftforge.gradle:ForgeGradle:2.3-SNAPSHOT’
classpath ‘org.spongepowered:mixingradle:0.4-SNAPSHOT’
classpath ‘com.github.jengelman.gradle.plugins:shadow:1.2.3’
}
}

apply plugin: ‘net.minecraftforge.gradle.forge’
apply plugin: ‘org.spongepowered.mixin’
apply plugin: ‘com.github.johnrengelman.shadow’

version project.modVersion
group project.modGroup

compileJava {
sourceCompatibility = targetCompatibility = JavaVersion.VERSION_1_8
}

minecraft {
version = project.forgeVersion
runDir = ‘run’
mappings = project.mcpVersion
coreMod = ‘com.gamesense.mixin.GameSenseMixinLoader’
makeObfSourceJar = false
}

repositories {
maven {
name = ‘spongepowered-repo’
url = ‘Repository - Nexus Repository Manager
}
maven {
name = ‘impactdevelopment-repo’
url = ‘Maven Repo | maven
}
maven {
name = ‘swt-repo’
url = “Redirecting...
}
maven {
name = ‘jitpack.io
url = “https://jitpack.io
}
maven {
name = ‘lukflug’
url = ‘Maven repo - lukflug's website
}
mavenCentral()
}

dependencies {
compile(‘org.spongepowered:mixin:0.7.4-SNAPSHOT’) {
exclude module: ‘launchwrapper’
exclude module: ‘guava’
exclude module: ‘gson’
exclude module: ‘commons-io’
}
compile ‘com.github.ZeroMemes:Alpine:1.5’
compile group: ‘net.jodah’, name: ‘typetools’, version: ‘0.5.0’
compile group: ‘com.googlecode.json-simple’, name: ‘json-simple’, version: ‘1.1.1’
compile group: ‘club.minnced’, name: ‘java-discord-rpc’, version: ‘2.0.1’
compile(‘com.lukflug:panelstudio:0.1.8’)
compile(‘com.lukflug:panelstudio-mc12:0.1.8’)
}

processResources {
inputs.property ‘version’, project.version
inputs.property ‘mcversion’, project.minecraft.version

from(sourceSets.main.resources.srcDirs) {
	include 'mcmod.info'
	expand 'version': project.version, 'mcversion': project.minecraft.version
}

from(sourceSets.main.resources.srcDirs) {
	exclude 'mcmod.info'
}

rename '(.+_at.cfg)', 'META-INF/$1'

}

shadowJar {
dependencies {
include(dependency(‘org.spongepowered:mixin’))
include(dependency(‘com.github.ZeroMemes:Alpine’))
include(dependency(‘net.jodah:typetools’))
include(dependency(‘com.googlecode.json-simple:json-simple:1.1.1’))
include(dependency(‘club.minnced:java-discord-rpc:2.0.1’))
include(dependency(‘com.lukflug:panelstudio’))
include(dependency(‘com.lukflug:panelstudio-mc12’))
}
exclude ‘dummyThing’
exclude ‘LICENSE.txt’
classifier = ‘release’
}

mixin {
defaultObfuscationEnv searge
add sourceSets.main, ‘mixins.gamesense.refmap.json’
}

reobf {
shadowJar {
mappingType = ‘SEARGE’
classpath = sourceSets.main.compileClasspath
}
}

jar {
manifest {
attributes(
‘MixinConfigs’: ‘mixins.gamesense.json’,
‘tweakClass’: ‘org.spongepowered.asm.launch.MixinTweaker’,
‘TweakOrder’: 0,
‘FMLCorePluginContainsFMLMod’: ‘true’,
‘FMLCorePlugin’: ‘com.gamesense.mixin.GameSenseMixinLoader’,
‘ForceLoadAsMod’: ‘true’,
‘FMLAT’: ‘gamesense_at.cfg’
)
}
}

build.dependsOn(shadowJar)

Pretty much this is all im making a skid of a hacked client

The sppnge api targetting would be really helpful. Based on your build and lack of answer to that my guess is your just wanting mixins and your plugin is actually a mod? If so thats why your getting the error as spongeGradle expects a plugin main

Yh its a mod how to fix it ?

So what are you trying to do?

Use the sponge api from your mod? Use mixins? Or something else.

I can fix something that i dont have the answer to and having to pry for a sliver of one

So you said if sponge is thinking its a plugin then it wont work. I asked you how i can make it think its a mod because it a mod not a plugin

I dont really know a lot about gradle.
I just wanna fix the error nothing else there are alot of ppl that fixed it but i dont know how thry did it thats why i gone to that post from 7 years ago

This goes back to the question i ask before.

What are you trying to do with your mod and sponge?

As in why do you want sponge in your code?

Use of mixins?
Use of the sponge API?

The way you have currently gone about it is the way that plugin developers would go. This does not work for your mod as sponge does not boot up sponge mods, only plugins. Therefore there is a different way for you, for me to tell you that way I need to know what your trying to do

I just want to launch minecraft with the mod nothing else
Heres the mod its not mine

Its a hacked client for anarchy servers

So thats a lot more useful as it answers all my questions.

So i tried building it myself.

Can i make sure you read its wiki on how to build it? Also make sure your running Java 8 at your JAVA_HOME

Im using java 8 yes but idk what wiki you talking about.
Also did it launch for you ?

The wiki on the github link you sent

As for launching it. I wont have java 8 as my main java anymore and can not be bothered doing all the process of adding it as my main, testing a bit of software that had stopped development to then make java 17 my main again.

But i will ask. How are you launching it?

In eclipse you just use java 8 jdk instead of the jre and use debug.it supposedly launch like that

(Edit) i just read the wiki. Do i just put the release file in my java launcher and launch it ?

The release file is a mod. So you put it in your clients mod folder

Is there a way to launch the master folder like a regular mod

What do you mean by “master folder”?

Also how can you launch a folder? A folder isnt code to launch?

I meant the github master .jar file can you run its code as a regular mod ?

Oh you mean branch code.

When the master branch is compiled. Yes you can

How to compile it all at once