CraftBook 4


#61

OK, I will be happy to use it smile
Great job to all and hope we will have a full release from Sponge and all plugins soon +1


#62

CraftBook now works on the latest sponge versions.


#63

Great thanks! :+1: Btw, when will you be able to add transportation pipes?


#64

I've tried it on dev 611 - 615 but it keeps crashing ...

Crash report

http://pastebin.com/embed_js.php?i=A4tLvXkB">


#65

It looks like the gradle shadow task isn't renaming properly. I'll have a check at it tomorrow.


#66

I have tested the latest release with sponge b613 and it doesn't work. See here: http://pastebin.com/U5E4Ze2L


#67

I had a look at that error, and it really doesn't make sense. It's complaining about a reference to something, even though that reference is never made at all.


#68

Hmm I don't know from this error more than you :frowning: hope you can find the problem. It was run on Sponge 613 with other mods: Dynmap (forge), PayDay, PEX, Spongeessential, TotalEconomy.


#69

Are you using SpongeForge with a forge server or SpongeVanilla?


#70

Dynmap isn't available for Sponge so he must be running SpongeForge :smile:


#71

I tried it with all other mods/plugins removed but It isn't working on my server either,


#72

All has set the Sponge, so I thing there is a Vanila, but be not sure.


#73

Yes, you have right, I needed it so i borrow it in the mean time from forge :frowning:


#74

I thing there can be a problem with the change to the new API or JAVA 8.


#75

Hi, your plugin still doesn't work with the latest version of Sponge-651

And is possible to write anywhere permission which use your plugin?
And I have also a feature request. Is possible to build there any possibility to integrate there a flag which give the ability to use the mechanism only admins or who has higher permissions? I mean all players can you it, but when I add these flag buy building the mechanism, then can use it only players with these special permissions. Maybe you can build it there more levels and in config file can we choose how much levels we will use.


#76

It should work now,

Permissions will be added shortly.


#77

OK thanks, and please upload it. There is only one week old build. Thanks.


#78

The latest build is very new


#79

I have now try it to start but only errors.
See this crash report: http://pastebin.com/suXfnexx

Thanks for hearing your users :smile: I will be happy to use it and have there the permissions.


#80

It doesn't work on this end either ...