CraftBook 4


#101

I'll have a look at that tomorrow.


#102

I plan on doing them when I get time.


#103

The plugin doesn't work for me. :anguished:

This is what I get:

[Sponge]: Failed to load plugin: com.sk89q.craftbook.sponge.CraftBookPlugin (from mods/CraftBook-4.0-SNAPSHOT.jar)
java.lang.NoClassDefFoundError: com/me4502/modularframework/exception/ModuleNotInstantiatedException
    at java.lang.Class.forName0(Native Method) ~[?:1.8.0_72]
    at java.lang.Class.forName(Class.java:264) ~[?:1.8.0_72]
    at org.spongepowered.server.plugin.VanillaPluginManager.loadPlugins(VanillaPluginManager.java:78) ~[VanillaPluginManager.class:1.8.9-3.1.0-BETA-235]
    at java.util.Map.forEach(Map.java:630) [?:1.8.0_72]
    at org.spongepowered.server.plugin.VanillaPluginManager.loadPlugins(VanillaPluginManager.java:63) [VanillaPluginManager.class:1.8.9-3.1.0-BETA-235]
    at org.spongepowered.server.SpongeVanilla.preInitialize(SpongeVanilla.java:136) [SpongeVanilla.class:1.8.9-3.1.0-BETA-235]
    at net.minecraft.server.dedicated.DedicatedServer.onServerLoad(SourceFile:60) [ko.class:?]
    at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(SourceFile:98) [ko.class:?]
    at net.minecraft.server.MinecraftServer.run(SourceFile:421) [MinecraftServer.class:?]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_72]
Caused by: java.lang.ClassNotFoundException: com.me4502.modularframework.exception.ModuleNotInstantiatedException
    at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:191) ~[launchwrapper-1.12.jar:?]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[?:1.8.0_72]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:1.8.0_72]
    ... 10 more
Caused by: java.lang.NullPointerException

#104

You've downloaded the wrong jar


#105

Well nowhere did it say what jar to download. The original post should have more information. What jar is for what? What do I download?


#106

Here is a link to the latest version,

http://builds.enginehub.org/job/craftbook/8412/download/CraftBook-4.0-SNAPSHOT-dist.jar


#107

While i love Craftbook, i'm wondering why PEX isn't reporting its permission nodes just like every other plugin.

I do /pex debug and then /help. This writes all permissions to the console (and logfiles) like this:

[12:04:44] [Server thread/INFO] [PermissionsEx]: Permission minecraft.command.tellraw checked in [] for system Server: 0

except the Craftbook perms. Why is it this way, am i missing something? :slightly_smiling:


#108

Can you update the description with more information. Someone who may not have prior experience with CraftBook may miss this plugin because they don't know what exactly it does.


#109

I'm not sure sorry, there's currently no docs on the Permissions API - And I haven't had time to properly look it over.


#110

Yeah sure, I'll do that now.

Maybe I'll also get the actual new docs working as well.


#111

Hi, only the elevator is working, it seems

using the door it says: you are not allowed to use this material...

When I specify the material eg: allowed-blocks=[
stone
]
it doesn't work either

Pipes don't work and the rest I haven't tried

//pastebin.com/embed_js/wN77m3n1


#112

I'll have a look when I get a chance


#113

Hello MM,

Got everything working except for pipes and after setting material for door, eg:=[stone], or =stone.(which one is correct btw?), it resets itself to "null" on server restart.
Also I'm missing the global config file, eg as in

http://wiki.sk89q.com/wiki/CraftBook/Configuration#AI_Mechanic_Configuration

... or isnt that included generally?

EDIT: Door is working BUT ONLY with oak planks. It would be nice if it worked with other blocks as well like before - So how can one change that?


#114

At a guess you havn't registered the PermissionDescriptions with the permission API.


#115

After downloading the latest and grabbing the functions I want, I get the following config file after restarting the server:

The list of mechanics to load.

Enabled-mechanics=[
Gate,
Elevator,
Door,
Pipes
]

This contains all disabled mechanics. It is never read internally, but just acts as a convenient place to grab mechanics from.

disabled-mechanics=[
GlowStone,
JackOLantern,
ICSocket,
MinecartEmptyDecay,
HeadDrops,
Gate,
TreeLopper,
Footprints,
Pipes,
Snow,
Bridge,
Door,
Netherrack
]

The list of mechanics to load.

enabled-mechanics=null

Strangely enough, the elevator works, the rest doesn't ...


#116

The one called enabled-mechanics should be set, not Enabled-mechanics. It's case sensitive.


#117

That would make sense, yes. Thanks


#118

Thats what I did, but got the result as shown above ... it reset itself and moved the enabled section to the top


#119

That's really odd, I'll talk to zml and see if there's a bug in Configurate causing the case to change.


#120

Whenever I shut down my server, I get this error.
http://paste.ubuntu.com/15210717/
It has always done this since I installed it. I have the latest version.

Also thank you for adding some more information in the OP. :smiley:
Just wondering, what are the other versions/artifacts, that end in "-javadoc", "-source"s, and nothing, for?