[Discontinued] AdminShop [v1.8.2] - Server Shops


You’re meant to do /setshop true to make it a “sell shop” as you call it

You might want to correct the ingame notification then, because that’s exactly what appears when using the command and I could find no information on how to use it properly.


I think it’s fine but I’ll double check


There is a bug that if you buy something with a full inventory then the item will go onto your head. Is this known about?


When will this be compatible with 1.11.2 and API 6?


Hey im stuck on the permissions stuff the signs work but how do i stop non admins from being able to edit the text on the signs thank you in advance :smiley:


Yes, soon it will be


Happen to have an ETA on that update for 1.11.2 by chance?


Hello, I’m currently hosting a server running FTB Beyond version 1.5.3 minecraft version 1.10.2, I setup a shop using your plugin and it works fine for me but when players try to use it it just zooms them in on the sign and pops up a message in the console saying player attempted to change an un-editable sign. It doesn’t take their money or give them the item. Thanks for any help.


The mod quark allows people to edit the signs. Disable sign editing in the mod config and the shop works. At least it works for me on our beyond server.


Okay I’ll try that, thanks. Is there a permission node for using the shop?


Hey I set the option in Quark to edit signs to false and restarted but it still does the same thing, zooms into the sign instead of buying the item.


What other plugins do you use from sponge?


Nucleus, LuckPerms, NuVotifier, RankUpper, ProjectPortals, TotalEconomy, and Inspector.
There was an option in Nucleus that just said Sign = enabled , I tried disabling that but it didn’t help either.


After looking into it more it looks like disabling Quarks ability to change signs doesn’t stop the UI from coming up, all turning it off does is stops the changes from going through… Any idea how to make AdminShop work around that?


The only other thing we use on our server is a protection plugin. So they aren’t allowed to edit signs but still able to click it. Admins however can still edit the sign.I dont know much else sorry.


What protection plugin do you use?


We are running Nations and our spawn is administration claimed.


I installed Nations and set up my spawn with an admin claim, still does the same thing. I have interactions turned off in the flags. this is the console message “[19:42:14] [Server thread/WARN]: Player Hansie0 just tried to change non-editable sign”


Well yes. But does it actually open the sign so they edit? They shouldn’t notice it.


It doesn’t let them buy it or edit it, I gave them interaction perms now to test that and now they can buy from it but it also lets them edit the sign