Early Crash Of Mixin

First time writing here, I don’t know if it’s a common issue but Mixin crashes really fast within Forge
Here are the logs
[18mars2023 12:52:16.622] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [–username, Cailaa, --version, 1.19.2-forge-43.1.7, --gameDir, C:\Users\Naphaëlla\AppData\Roaming.minecraft, --assetsDir, C:\Users\Naphaëlla\AppData\Roaming.minecraft\assets, --assetIndex, 1.19, --uuid, 989893dcd797409680ec43da306751ae, --accessToken, ???, --clientId, M2Q0Y2FiMmEtNGFjZS00NjQ0LWFmMzMtZmY4ODUzODRhNTdm, --xuid, 2535450565137768, --userType, msa, --versionType, release, --width, 1920, --height, 1080, --launchTarget, forgeclient, --fml.forgeVersion, 43.1.7, --fml.mcVersion, 1.19.2, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20220805.130853]
[18mars2023 12:52:16.629] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 10.0.8+10.0.8+main.0ef7e830 starting: java version 17.0.3 by Microsoft; OS Windows 10 arch amd64 version 10.0
[18mars2023 12:52:16.785] [main/INFO] [mixin/]: SpongePowered MIXIN Subsystem Version=0.8.5 Source=union:/C:/Users/Naphaëlla/AppData/Roaming/.minecraft/libraries/org/spongepowered/mixin/0.8.5/mixin-0.8.5.jar%2391!/ Service=ModLauncher Env=CLIENT

Third line seems to be the problem, reinstalled forge multiple times along Minecraft and Java
Read some similar topics but none of them seemed to be relatable to my case
I already erased all of my mods so I really don’t know what’s the issue here
Thanks for taking the time to read me

Sadly mixins while created by sponge, isnt something we are responsible for (unless its in sponge). Instead a mod is using it and it is responsible for it.

Your log doesnt seem to be complete and therefore I cannot see the mixin file that is causing the error so I wont be able to tell you the exact mod causing it.

With that being said, i can filter down your mods list to those mods with mixins. I have made a program that will filter down your mods to those with mixins. It has filters that can be applied too if you know things to filter by.

There’s no mod loaded when I try to use Forge, and the lines that I sent were the only ones in the log file

Ah in that case a mod at some point put the mixin library in your library folder


You should be able to just delete it

So do I have to put the mixin library elsewhere or delete the mixin library ?

So I just deleted it, but the error still stays the same, even though there’s no mixin library now…

Source=union:/C:/Users/Naphaëlla/AppData/Roaming/.minecraft/libraries/org/spongepowered/mixin/0.8.5/mixin-0.8.5.jar%2391!/ Service=ModLauncher Env=CLIENT

What can I do now ?

Did you delete the file or the folder that contains it?
(Also remove it from your recycling bin as I know sometimes mod loaders (in this case library loader) can still detect it if its not fully deleted)

I did delete it and removed it from my recycling bin but even though I did not have any mods, the file reappeared
I believe it’s each time I launch forge even if I have not any mods loaded/in my mods file
I even deleted the org file and the same error still pops up
Okay, after relaunching the launcher and booting up forge, the org file downloaded with the mixin library, it seems the forge version is attached with the mixin library even if I don’t have any mod running

Okay so, I tried emptying my config file, and it seems to have worked, Forge runs now. Thanks for the answers though !
Have a nice day, this reply can be qualified as the solution I think