Game crashes while loading worlds

Howdy! I’m trying to make a modpack for personal use using CurseForge launcher, and the modpack would never even reach the title screen. I believe the fix for that was disabling Flywheel, but afterwards whenever I attempted to create a world my game would crash with the following:

The game crashed whilst unexpected error
Error: org.spongepowered.asm.mixin.transformer.throwables.MixinTransformerError: An unexpected critical error was encountered

Exit Code: -1

Here’s my crashlog:

And here’s my modlist:

Apologies for any formatting issues, i’m not very active on forums.

You actually got the formatting spot on in the fact you provided a pastebin link. Most people just bring the error directly into the forums destroying formatting and bringing a wall of text.

As for you issue. You dont have sponge installed so its not a fault of sponge and therefore we are limited in what we can do.

Essentially a mod of yours is using mixins (made by sponge) and either a mod isnt playing nice with mixins or the mod with the mixins isnt using it right.

I cant tell you either mod, but I can show you one of my programs that detects what mod has mixins (sadly it cant work out what mods have issues with mixins).

Hopefully on the mixins website there is a list of issues or mod incompatibilities that has the other mod in and hopefully there is a way to get both working

1 Like

Your program worked perfectly but wasn’t all that useful for me as 53 out of 95 mods have mixins, I eventually just brute forced it by removing specific mods until it worked and it turned out to be Oculus & Rubidium that crashed my worlds. Sorry for wasting your time but thank you for trying to help. :slight_smile:

Didnt waste my time. My program actually has a filter where you can provide a crash log, so its good news to me that I need to make it more obvious (im not a ux/ui person).