⚙ UltimateCore - The Best Essentials Plugin! (API 7, MC 1.12)


#21

UltimateCore v3.0.0 has been released!

Initial release! Click here to download.

This is an alpha build and far from ready for production server use.
I made a temporary documentation here. I know this may be a bit confusing but a better documentation is coming soonTM.


#22

how do we use the tablist?


#23

In the config located at config\ultimatecore\modules\tablist.conf you can configure how the tablist looks.


#24

my tablist.conf is blank, how do i configure it and does it support ranks?


#25

It does support ranks.

That’s weird, it shouldn’t be blank.
Are all other config files blank too?
Are there any errors in the console?
Can you try deleting all the blank files?


#26

the commands.conf, general.conf and modules.conf are all there and so is the language folder witht he english is there, thats it.


#27

let me see if theres any errors in console


#28

[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at bammerbom.ultimatecore.sponge.impl.module.UCModuleService.registerModule(UCModuleService.java:90)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at bammerbom.ultimatecore.sponge.UltimateCore.onPreInit(UltimateCore.java:145)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at org.spongepowered.common.event.listener.GamePreInitializationEventListener_UltimateCore_onPreInit1.handle(Unknown Source)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at org.spongepowered.common.event.RegisteredListener.handle(RegisteredListener.java:95)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at org.spongepowered.mod.event.SpongeModEventManager.post(SpongeModEventManager.java:301)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at org.spongepowered.mod.event.SpongeModEventManager.post(SpongeModEventManager.java:330)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at org.spongepowered.mod.SpongeMod.onStateEvent(SpongeMod.java:229)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at java.lang.reflect.Method.invoke(Method.java:498)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at com.google.common.eventbus.EventBus.post(EventBus.java:275)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at net.minecraftforge.fml.common.LoadController.sendEventToModContainer(LoadController.java:243)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at net.minecraftforge.fml.common.LoadController.propogateStateMessage(LoadController.java:221)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at java.lang.reflect.Method.invoke(Method.java:498)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at com.google.common.eventbus.EventBus.post(EventBus.java:275)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at net.minecraftforge.fml.common.LoadController.redirect$onPost$zzb000(LoadController.java:52)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at net.minecraftforge.fml.common.LoadController.distributeStateMessage(LoadController.java:145)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at net.minecraftforge.fml.common.Loader.preinitializeMods(Loader.java:614)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at net.minecraftforge.fml.server.FMLServerHandler.beginServerLoading(FMLServerHandler.java:98)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at net.minecraftforge.fml.common.FMLCommonHandler.onServerStart(FMLCommonHandler.java:328)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:121)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:431)
[08:58:13] [Server thread/INFO] [STDERR/sponge]: bammerbom.ultimatecore.sponge.UltimateCore:onPreInit:155: at java.lang.Thread.run(Thread.java:745)


#29

I already fixed this issue after the release, so it is not included in the jar you have.
Didn’t think it would actually affect someone.

Can you try if this jar solves the problem?
https://www.mediafire.com/?2j4ki426o62m2mn

EDIT: You might have to delete your modules.conf file when installing this update


#30

ok will do. gonna boot it up again and see if it works :slight_smile: thanks for the quick response.


#31

UltimateCore v3.0.1 has been released!

New release! Click here to download.

This is an alpha build and far from ready for production server use.
I made a temporary documentation here. I know this may be a bit confusing but a better documentation is coming soonTM.

New/Changed:

Fixed:

  • Fixed errors while registering permissions
  • Fixed issues with modules not loading and blank module configurations
  • Fixed /burn usage
  • Fixed /tpa
  • Fixed hovering playernames in deathmessages

#32

UltimateCore v3.0.2 has been released!

New release! Click here to download.

This is an alpha build and far from ready for production server use.
Documentation: https://github.com/Bammerbom/UltimateCore/blob/master/docs/home.md

New/Changed:

  • Added /createkit and /removekit
  • Added vanish module
  • Added exempt permission options for deaf, jail, mute and kick.
  • Added documentation

Fixed:

  • Fixed success count for teleport module
  • Fixed running UltimateCore on a forge client

#34

You got a syntax error on line 62, 69 and 76.
There is no " at the end there.

Also, you should not remove these fields from the config, but instead make them empty. UltimateCore might not like it if you remove them.


#35

You were right about the syntax errors, not sure how I didn’t see that. I added them and it seems to be working just fine now! Thank you for your assistance.


#36

A new version has been released for UltimateCore, it is available for download here.


This is an alpha build and far from ready for production server use.
Documentation: https://github.com/Bammerbom/UltimateCore/blob/master/docs/home.md

  • Added item commands:
    /itemname
    Change the name of the item in your hand.
    /itemlore
    Change the lore of the item in your hand.
    /itemquantity
    Change the quantity of the item in your hand.
    /itemdurability
    Change the durability of the item in your hand.
    /itemunbreakable true/false
    Change whether the item in your hand is unbreakable.
    /itemcanbreak [Block] [Block]…
    Change the blocks this item can break.
    /itemcanplaceon [Block] [Block]…
    Change the blocks this item can be placed on.
    /itemhidetags attributes/candestroy/canplace/enchantments/miscellaneous/unbreakable false/true
    Change whether a certain tag is hidden.
    /itemenchant [Level]
    Add an enchantment to the item in your hand.

  • Added some extra bstats charts

  • Added blacklist module (ban certain items)

  • Added geoip module (%country% variable and /country command)

  • Added votifier module (Vote handling)

  • Added %uuid% variable

  • Changes to permissions, shouldnt break any permissions

  • Fixed timed jails

  • Fixed some internal config logic


#37

Nice work man, I hope this Project will reach a beta version soon :smiley:


#38

I tested now your plugin and it’s really pretty cool, but there are some things to fix, for example: for me is the tablist and the custom chat per group not working.
Im using Pex to handle groups and permissions, please solve this, when this two things work thant I can use this plugin on my server.
Thanks in advance!


#39

Could you please specify ‘not working’?
Any errors? Is it just not doing anything?
And please send me your config.


#40

Ok, It gives no errors in console, and the error option is on true, I add the groups in the config but the tab remains yellow as default for your plugin and the chat is a mix of color codes and so on.
Here are my config and a screen:



http://www.mediafire.com/file/27fos7eb5toaele/configs.zip


#41

Here are your mistakes:

  • You should enable headers & footers for the talist
  • You should read the comments in both configs at the group part:

You can give a user the permissionoption uc.chat.group
For example, if you set this option to ‘admin’, the admin group is used for formatting.
YOU CAN’T USE GROUP NAMES ANYMORE!

And

You can give a user the permissionoption uc.tablist.group
For example, if you set this option to ‘admin’, the admin group is used for formatting.
YOU CAN’T USE GROUP NAMES ANYMORE!

Using pex you can set permissionoptions using the following commands
/pex group founder option uc.chat.group founder
/pex group founder option uc.tablist.group founder

I have no idea why the colors in the chat aren’t working, I copied your config and for me they are.

EDIT: I found the problem with your colors. Color codes in permission prefixes and suffixes aren’t working and this will be fixed in the next update.