LuckPerms | An advanced permissions plugin


#265

This may suit your needs? :slight_smile:


#266

Does this work ok with GriefPrevention on Forge 1.10.2 (with Pixelmon 5.0.2)? I don't need any groups other than default and the default permissions that come with griefprevention, These are in place by the looks of it, however the gold shovel reports "You don't have permission to claim land". The initial chest placement works and creates a plot, but no commands, like /abandonclaim work - "You do not have permission to use this command". Am I missing something about the default group? I normally use GroupManager so understand groups and perms, but its my first time to use LuckPerms.

here's the output from using the gold shovel with debug on:

10:21:52 PM CONSOLE: [LP] LOG > Checking null for: griefprevention.flag.interact-item-secondary.minecraft.golden_shovel.source.minecraft.player (UNDEFINED)
10:21:52 PM CONSOLE: [LP] LOG > Checking null for: griefprevention.flag.interact-item-secondary.minecraft.source.minecraft.player (UNDEFINED)
10:21:52 PM CONSOLE: [LP] LOG > Checking local:defaults/default for: griefprevention.flag.interact-item-secondary.minecraft.golden_shovel.source.minecraft.player (UNDEFINED)
10:21:52 PM CONSOLE: [LP] LOG > Checking local:defaults/default for: griefprevention.flag.interact-item-secondary.minecraft.source.minecraft.player (UNDEFINED)
10:21:52 PM CONSOLE: [LP] LOG > Checking local:defaults/default for: griefprevention.flag.interact-item-secondary.minecraft.golden_shovel.source.minecraft.player (TRUE)
10:21:52 PM CONSOLE: [LP] LOG > Checking null for: griefprevention.flag.interact-block-secondary.minecraft.sand.source.minecraft.player.0 (UNDEFINED)
10:21:52 PM CONSOLE: [LP] LOG > Checking null for: griefprevention.flag.interact-block-secondary.minecraft.source.minecraft.player.0 (UNDEFINED)
10:21:52 PM CONSOLE: [LP] LOG > Checking local:defaults/default for: griefprevention.flag.interact-block-secondary.minecraft.sand.source.minecraft.player.0 (UNDEFINED)
10:21:52 PM CONSOLE: [LP] LOG > Checking local:defaults/default for: griefprevention.flag.interact-block-secondary.minecraft.source.minecraft.player.0 (UNDEFINED)
10:21:52 PM CONSOLE: [LP] LOG > Checking local:defaults/default for: griefprevention.flag.interact-block-secondary.minecraft.sand.source.minecraft.player.0 (TRUE)
10:21:52 PM CONSOLE: [LP] LOG > Checking null for: griefprevention.user.claim.create (UNDEFINED)
10:21:52 PM CONSOLE: [LP] LOG > Checking null for: griefprevention.flag.interact-block-secondary.minecraft.sand.source.minecraft.player.0 (UNDEFINED)
10:21:52 PM CONSOLE: [LP] LOG > Checking null for: griefprevention.flag.interact-block-secondary.minecraft.source.minecraft.player.0 (UNDEFINED)
10:21:52 PM CONSOLE: [LP] LOG > Checking local:defaults/default for: griefprevention.flag.interact-block-secondary.minecraft.sand.source.minecraft.player.0 (UNDEFINED)
10:21:52 PM CONSOLE: [LP] LOG > Checking local:defaults/default for: griefprevention.flag.interact-block-secondary.minecraft.source.minecraft.player.0 (UNDEFINED)
10:21:52 PM CONSOLE: [LP] LOG > Checking local:defaults/default for: griefprevention.flag.interact-block-secondary.minecraft.sand.source.minecraft.player.0 (TRUE)

Here are the versons:
spongeforge-1.10.2-2221-5.2.0-BETA-2223.jar
griefprevention-1.10.2-2.3.1.271.jar
LuckPerms-Sponge-3.0.35.jar

forge-1.10.2-12.18.3.2202

Cheers, F451


#267

I suggest reading the GriefPrevention wiki pages.


#268

meh. There were other questions in there. No need to be so ...I will find another perms plugin. Thanks.


#269

Iit's generally not the job of one developer to explain the plugins made by another dev - especially when there is an excellent Wiki that actually goes into detail about how to make them work together. YMMV.


#270

Well the issue was fixed with PermissionsEX and half a dozen PermissionsEX commands. Nothing to do with GP. All done now.


#271

Just thought I'd chime in for anyone having similar issues with LuckPerms (as I was) - the specific command you probably want to run to fix GriefProtection (as noted at the bottom of the wiki page they linked above) is

lp group default permission set griefprevention.user

This fixed GP for my default group, but I'm still having trouble with granting additional Nucleus command permissions to the default group. Maybe there is something I'm missing on the Nucleus documentation. I've already done setupperms and assigned the appropriate groups to their corresponding "recommended" settings from Nucleus. Those recommended commands work OK, but so far I have been unsuccessful in getting other commands to work. For instance I ran

lp group default permisison set nucleus.tppos

But default group users still can't use tppos. Is there something obvious I am missing?


#272

Are you sure that's the correct permission for the tppos command? Check the Nucleus documentation to find the right one. :stuck_out_tongue:


#273

Thanks, yeah I figured it out just a few minutes ago...
lp group default permission set nucleus.teleport.tppos.base
That did it!


#274

I am having an issue and I feel ive tried to find an answer well enough to ask:
Using luckperms and commandsigns together I am attempting to make a sign that when right-clicked will add the user to a group.
The command Ive been trying to make work is this:

"#/lp user @p parent set "

it seems luckperms doesnt like the @p selector as it isnt a username or uuid.
I am running Nucleus as well, if that matters.
I have also tried with a "^" instead of the "#".

Any suggestions?


#275

Not sure. LP doesn't implement any specific support for selectors. I don't know if that's a Sponge thing, or something with CommandSigns, Nucleus, etc. Perhaps try asking the CommandSigns author if they know why it's happening.


#276

It's up to the command to implement selectors last i checked, ie LuckPerms


#277

Is there a quick way to just remake the OP group as it was?
I'm running a very small server for friends, but I needed a permissions plugin to make another plugin work, and now I don't have any of the permissions I need for testing and such.


#278

/lp creategroup op
/lp group op permission set * true
/lp user <you> parent set op

#279

Oooooh.
In hindsight, that should have been obvious and I feel silly for not thinking of it.
Thank you! :smiley:


#280

Hi Luck,

Now I am translating your lang.yml from English to Spanish, but I have a doubt...

Do I just translate the message between " " or also the command ???

Heres a piece of the file....what should I translate?

command-not-recognised: "Command not recognised."
command-no-permission: "You do not have permission to use this command!"
already-haspermission: "{0} already has this permission!"

keep going! You're doing a great job


#281

The key should remain the same (the bit before the colon)

The English version might look like:
command-not-recognised: "Command not recognised."

The translated version should be:
command-not-recognised: "-- translated message goes here --"


#282

Perfect...

Something like this:

The English version might look like:
command-not-recognised: "Command not recognised."

The translated version should be:
command-not-recognised: "No se reconoció el comando."


#283

Yes, that's correct.


#284

Language file completely translated from english_USA to spanish_ECU

Where can I send you the file? I am not allowed to upload it in the comment.

I hope I have been of great help.