💰 EconomyLite v2.13.0 | API 7.0

This thread is now closed. Please view the plugin on Ore for updated information.

13 Likes

Always great to see new Economy plugins. Competition is the stuff of awe.

2 Likes

Thats more of a modular feature

Also, don’t forget to update your thread body with the new name. :stuck_out_tongue:

1 Like

:stuck_out_tongue_closed_eyes: Whoops thanks for reminding me!

1 Like

Recently, there had been a lot of W.I.P Economy plugin which is a good thing. Wish you good luck!

3 Likes

This also applies to you: [Economy] Total Economy v1.7.1 - #2 by boformer

It would be nice if all eco plugins would implement the SAME service interface.

XML is probably the worst possible way to store often-accessed data.

1 Like

EconomyLite v0.0.2 has been released!

This thread will only be pushed with new release updates every so often, so check GitHub for the latest release

Download Link

Source Code

1 Like

EconomyLite v0.0.4 has been released!

This thread will only be pushed with new release updates every so often, so check GitHub for the latest release

Changes:

  • MySQL Database support
  • Fixed wording in a message (@tomudding)
  • Changed configuration file location

Download Link

Source Code

Issue Tracker

EDIT: EconomyLite v0.0.5 has been released! View the release here.

1 Like

EconomyLite v1.0.0 has been released!

This thread will only be pushed with new release updates every so often, so check GitHub for the latest release

Changes:

  • Complete rewrite
    • Cleaner, more efficient code
    • Easier to read
  • Support for businesses
  • Multi-threading
  • Notifications when updates become available
  • Plugin Metrics

Download Link

Source Code

Issue Tracker

EDIT: The full documentation for the EconomyLite API has been completed! View it on the wiki here.

Help craft EconomyLite into the economy plugin with all of the features you want! Click here to suggest a feature via Google Forms!

UPDATE: EconomyLite v1.0.1 has been released! All of the above links are still applicable

1 Like

EconomyLite v1.0.2 has been released!

Changes Include:

  • Support for Sponge v1.8-1499-2.1DEV-562
  • The update-notifier will now display the changes made in a release, if they can be found

:inbox_tray: Download EconomyLite v1.0.2

:bangbang: Issue Tracker

:memo: Feature Suggestions

:wrench: Source Code

:books: Wiki

:bookmark: Developer API

:heavy_dollar_sign: Like my work? Please Consider Supporting Me!

UPDATE: You can now add EconomyLite as a Maven dependency to your project instead of adding it as an external JAR file! Click on the “Developer API” link above to learn more!

2 Likes

Hi,
Is it working with the latest Sponge build?
While I have only crash and with this plugin the MC will not start.

Thanks.

If you could please upload your latest log to pastebin, GitHub, or a service like that, and then leave a link to to that from the forums. If I don’t have the log and I can’t help you :cry:!

Here is the crash log: http://pastebin.com/vxmDStgq
Hope it help. Thanks.

It appears that you are running Java 7, which is no longer being supported by Oracle. To solve this issue simply upgrade to Java 8. If you can’t do this for some reason, just let me know and I will implement support for Java 7.

I’m runnung Java 8 (build 1.8.0%51-b16). Its the lated one.

Java Version: 1.6.0_65, Apple Inc.

Nope, You are running 1.6 :stuck_out_tongue:

See picture:

And when I look Java Versions on system there is only one 1.8 … I don’t understand it.
How can it then run old java. Is any possibility to switch it when there are both?

This tool may help you: http://java.com/en/download/uninstallapplet.jsp

It should check for old Java versions and remove them if it finds any.