NuVotifier - Votifier with more robust code and vote forwarding


#62

I keep getting this

Even after restarting PC. it doesn't work when people vote


#63

I don't get any error or anything when I try to vote


#64

Then the votes are not going through. You most likely didn't set it up properly.


#65

But it is set up correctly, the vote sites don't seem to connect to the server despite the public key being correct, port and IP correct, port open. I'm at a loss.


#66

https://mctools.org/votifier-tester


#67

I've tried several of those, they don't work either


#68

That means its your server, not the plugin. Who are you hosting through?


#69

I host it myself, I've never had issues with voting before on my 1.7.10 servers.


#70

Ah man I hope someone could help me out with this... I have the nuvotifier with simplevotifier work perfectly and all a sudden Im not receiving the broadcast and the reward in game after voting...

I tried verifying with the test and it sends to the game but nothing happens in the console... I tried to remove it and re adding a fresh config and still the same thing... I even had a backup that I restored and still not getting the in game notification after the votifier was successfully sent... not even sure where to look at this point...


#71

My problem was to do with my port, it was open and listening but they weren't getting through, my tech guy was just messing with it when it started working again.


#72

I have a config question that I felt might be better here instead of on Github since it's not a bug or game-breaking issue.

I have an Enjin site that seems to have its own vote listener in their plugin. Enjin-based votes will be for the enjin site and in-game votes for the Minecraft server.
Then for Minecraft I have a bungee server, a hub, play server and build/test server.

How would I set up the config? I won't need voting active on my test/build server, and I'm thinking of only permitting casting votes on the hub, but rewards sent to wherever they are if they switch servers between casting and registering the vote.

I am going to make an assumption and say I put the bungee address in the config and change forwarding.method to "pluginmessaging" and forwarding.pluginmessaging.channel to "bungee".
Please correct me if I'm mistaken.


#73

Hey, I’ve been having a lot of issues trying to get votes to go through.

I’m using seriousvote with this and whenever I do /givevote from that it sends the rewards as it should. However, every time I vote, it gives this error in console and the vote doesn’t go through.


#74

Are you ever going to update this plugin to work with Sponge api 7 cause it seems like updates have stopped for this plugin.


#75

[16:39:45] [pool-3-thread-4/ERROR] [Sponge]: The Scheduler tried to run the task nuvotifier-A-104 owned by Plugin{id=nuvotifier, name=NuVotifier, version=2.3.5, source=W:\pixelmonserver.\mods\plugins\serious-nuvotifier-universal-2.3.5(1).jar}, but an error occured.
java.lang.NoClassDefFoundError: org/spongepowered/api/event/cause/NamedCause
at com.vexsoftware.votifier.sponge.VotifierPlugin$3.run(VotifierPlugin.java:382) ~[VotifierPlugin$3.class:?]
at org.spongepowered.api.scheduler.Task$Builder.lambda$execute$0(Task.java:139) ~[Task$Builder.class:1.12.2-2705-7.1.0-BETA-3133]
at org.spongepowered.common.scheduler.SchedulerBase.lambda$startTask$0(SchedulerBase.java:186) ~[SchedulerBase.class:1.12.2-2705-7.1.0-BETA-3133]
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [?:1.8.0_171]
at java.util.concurrent.FutureTask.run(Unknown Source) [?:1.8.0_171]
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [?:1.8.0_171]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [?:1.8.0_171]
at java.lang.Thread.run(Unknown Source) [?:1.8.0_171]
Caused by: java.lang.ClassNotFoundException: org.spongepowered.api.event.cause.NamedCause
at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:191) ~[launchwrapper-1.12.jar:?]
at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_171]
at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_171]
… 8 more
Caused by: java.lang.NullPointerException

I’m getting this error when I receive a vote on my server, anyone know the reason?


#76

As of today, 8/29/2018, curscascis says his SeriousVote and Serious NuVotifier plugins are up-to-date, actively maintained, and working for Sponge APIs 4, 5, 6, and 7. He also says that anyone who needs help should contact him using the Discord he links to on his SeriousVote page.


#77

I have updated this thread to the NuVotifier releases page so as to make sure people are not redirected to the very old v2.3.4. As of this writing it’s up to 2.4.1 and is fully SpongeAPI 7-compatible.


#78

This is probably super dumb, but I’ve added this to the mods folder, and cannot seem to figure out what to do. /vote doesn’t work, and I don’t see any place to configure anything :frowning: