Server Crashes after addition of SpongeForge

Hello community,

i have the problem, i have a standard forge server (Version 1.10.2 and 2477).
and i want do add Sponge because i want plugin support. The Server works perfectly fine when using just Forge (with mods) but after i add sponge to the Mods folder the server crashes while starting.

The errormessage is:

[13:00:18] [Server thread/INFO] [Sponge]: /* Technical details: /
[13:00:18] [Server thread/INFO] [Sponge]: /
[13:00:18] [Server thread/INFO] [Sponge]: /
Failed on class : /
[13:00:18] [Server thread/INFO] [Sponge]: /
During phase : DEFAULT /
[13:00:18] [Server thread/INFO] [Sponge]: /
Mixin : world.gen.structure.MixinMapGenStronghold /
[13:00:18] [Server thread/INFO] [Sponge]: /
Config : mixins.common.core.json /
[13:00:18] [Server thread/INFO] [Sponge]: /
Error Type : org.spongepowered.asm.mixin.injection.throwables.InvalidInjectionException /
[13:00:18] [Server thread/INFO] [Sponge]: /
Caused by : Unknown /
[13:00:18] [Server thread/INFO] [Sponge]: /
Message : @Inject annotation on handler$onGetNearestStructurePos$zmd000 could not find ‘getNearestStructurePos’ */

Here the full server log:

it would be cool, if you could help me.
Thanks in advance.

Sincerly Marvin

Hello, please could you post your full crash report?

1 Like

There is no real crashreport, at least not in the crash report folder…

Edit: This is the only Crashreport i found, but i already fixed it, by deleting the Sponge version of Worldedit

Try deleting or moving WorldEdit Forge out of the mods folder. It looks like the server just doesn’t like you have Sponge and Forge WorldEdit being loading at the same time.

You can always use the sponge version of WorldEdit instead of the Forge version. It does the same job

They did say that they fixed that crash…

Anyway, I don’t know what’s causing your issue, looks like something to do with world gen though.

By the way, I noticed that you have both JEI and NEI…

Good luck!

1 Like


yeah i already deleted the forge version of WorldEdit ^^

But anyways is it bad to have JEI and NEI? (I didnt set up the server, im just the one who has to fix the sh*t :stuck_out_tongue: )

Yeah, after i deleted our map from the server and it generated a new one it worked (some what),
but it doesnt load any plugins. I used the sponge forge mod (spongeforge-1.10.2-2477-5.2.0-BETA-2637) and i want to use CraftBook. At first i added Craftbook to the mods folder, then i created a plugin folder in the mods folder, but both times it just says: [FML] : FML has found a non-mod file craftbook-core-4.0-SNAPSHOT-original.jar in your mods directory…

Any ideas?

Thanks in advance.

Is this the CraftBook you meant?

You seem to have downloaded the core version, which I’m assuming is the Spigot/Bukkit version, try the specific Sponge version. Which if that is correct, it’ll be why it’s causing the FML error about it not being a mod.

Also yes, you can’t have both JEI and NEI, they’re essentially the same mod. I recommend JEI over NEI.

  • Alice
1 Like

Yes exactly,

Yes i did and it worked (some what) now i have the problem that i can’t find the right version o.O I have to use the 5.2.0 API Version of Sponge, but i cant find the right version of CraftBook… the newest is for API Version 7.0.0
How on earth am i supposed to find the right version here o.O (

Again Thank you :stuck_out_tongue:

These are the 1.10.2 builds


Yes, perfect thank you!

Now local test server runs perfectly, but after i loaded it on our public server everything went bad…
Here is a short version of the console: uid=8504(ni360075_2) gid=8508(ni360075_2) groups=8508(ni360075_2),4408(overviewr - (the long version is too long for pastebin)

The server doesnt find any mods anymore…

Any ideas?

sincerly Marvin

I’m not seeing anything wrong in that log, the issue is probably in the long version.

However, you shouldn’t have optifine installed on a server. That could potentially be the issue.

1 Like