[SOLVED] (GRADLE) Sponge Implementation Build Failed

Hello again fellow developers,

I have successfully cloned the Sponge Implementation into a local directory on my computer (thanks to @simon816’s help) and, upon running the ./gradlew command in my unix command line, I am produced with a red message notifying me that the build has failed. As per the instructions on the github repository, this command should build the Sponge Implementation and pack it into a jar located in the ./build/libs directory. However, this is not the case because the build fails with the following error message:

:javadoc FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ‘:javadoc’.
Javadoc generation failed.

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.


Total time: 1 mins 13.427 secs

I have no idea how to go about fixing this, so any help would be greatly appreciated.

You need to run
git submodule update --init --recursive
before building

1 Like

No need to worry about that. Those are just the javadocs. Sponge documentation lives at https://docs.spongepowered.org

1 Like

Sorry for the delay @simon816 and @IronManDoesMC, but I have run the “git submodule update --init --recursive” command and the “./gradlew setupDecompWorkspace --refresh-dependencies” before building and it still didn’t work.

Also, I understand that the error only involves the javadocs, which are unnecessary, but it also prevents a jar file from being created.

That’s likely another error then, though when I tested the following commands it worked fine:

In a clean directory
$ git clone https://github.com/SpongePowered/Sponge.git .
$ git submodule update --init --recursive
$ ./gradlew setupDecompWorkspace --refresh-dependencies
Some time later…


Very strange, it must be a mac thing.

Not always mac, Linux too, since they’re both based of Unix.

1 Like

It happens for me as well on Windows. For now, you can exclude the javadoc task in the building process using the -x javadoc switch.

1 Like

I’m having a different problem:

Found AccessTransformer in main resources: sponge_at.cfg

FAILURE: Build failed with an exception.

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.


Total time: 13.649 secs

Why can’t I access the file? I don’t understand…

You need to set up forge by running either
gradlew setupDecompWorkspace
gradlew setupDevWorkspace
gradlew setupCIWorkspace

1 Like

Yes, that worked. I can’t really understand why, though…

1 Like

Thank you so much! :slight_smile: I like Sponge!

1 Like

Thank you very much! That fixed it :).