UNMAINTAINED - 🌍 Nations [v2.5] - Towny-like protection plugin


#135

My bad, thanks for reporting !


#137

Please put the plugin version in the forum topic so we can know at a glance what version it is on when updating.(workaround till they get the plugin repository online)


#138

If you think it helps, here it is :wink:


#139

I’m trying to claim the spawn on my server using this and I can figure out how to claim it all without making it so everyone has that amount of claims available to them as spawn is quite large and if everyone could eventually claim that large of space that Is going to cause problems for me.
currently I’m making it in the config that you can buy a large amount of extra claims as I cant figure out how to allocate extra claim blocks to a specific town using an admin command


#140

Indeed, there is currently no command to give a nation a arbitrary number of extra blocks. I’ve opened an issue for that. I’ll work on this as soon as possible.


#141

so I’m having the problems of people trying to claim for their nation, and it says they are to close to a nation when there isn’t one nearby, is the check seeing their own nation?


#142

It depends on the value that is specified as minNationDistance. But for your problem, have you tried creating an admin nation ?


#143

Nations Release v2.1

Targets SpongeAPI v5.0.0

Nations Release v1.1

Targets SpongeAPI v4.2.0

Changelog

  • Fixed error in tax collector
  • Fixed /na claim <nation> command being unregistered

#144

Hey!

I had just created a nation, and while attempting to run the command “/n spawn home”, the command does not work while returning this error in console.

Using latest version of plugin, I believe and API 5 sponge jar

Thanks.


#145

I big issue ive been having that needs to be sorted is that normal palyers can create a nation in most places.Yes, it says too close to a nation BUT in my config ive set minNationDistance=1 and ive reloaded and restart the server multiple times and its still one so can someone please help with this people on my server are unable to claim land in most places.

Im also using sponge api 5 on 1.10.2


#146

@Adnan

That error is quite strange, I’ll work on that asap.

@Vexall

I’ve not fully understood what you meant but concerning the minNationDistance parameter in config file, you need to set it so it’s bigger than 1000 at least. To be precise, the algorithm that checks if a point is far enough from a nation checks if it’s far enough from all the points of the rectangles that forms the nation’s territory. That’s why you need to have a minNationDistance bigger than the size of the biggest rectangle of all nation territories.


#147

The thing is 1000 is so big like people have to travel so so much litrally after creating 10 farily far apart nations it makes it impossible to do anything my server has about 20 players and its only a week old almost and now no one can really claim its always saying too close is there no way if diableing the minnation distance to me its something useless i want my players to be able to claim anywhere some people wnat to make nation next to nation but they cant


#148

I’ll see what I can do for that.


#149

Okay, thanks! Hopefully, you found a fix soon.


#150

“Error Occurred while executing command: No value present”

I claimed land with /na create spawn then used /na claim spawn.

After I tried to type /na perm Spawn outsider interact 0 but it didn’t work. Please help.

running the lastest version of sponge forge 1.10.2

EDIT - Figured Issue out. Just had to reinstall plugin accidentally messed up config file.


#151

You need to provide a stacktrace of your error for us to help you. Paste it on a pastebin or on your reply surrounded by 3 `


#153

Is it possible to set within a nation a Zone; however, in this zone allow users to only break a specific block such as a Spawn tree farm or something? with a command such as /Zone perm citizen build limited Then when in zone to add blocks to something like /zone perm citizen block add Minecraft:grass etc etc etc


#154

Unfortunately, it would imply too much work. I get more and more busy so I’d like to fix all bugs first and limit the number of big planned features if they are not essentials.

Also for your error, can you paste a stackttrace so I can see if there’s something to fix in the code ?


#155

I have an error with the golden axe:
http://pastebin.com/zA1PWacm

maybe this is useful:


#156

@Witchcrafter1 You downloaded the Nations Version for SpngeAPI-4, check the download page for the 2.1 version of Nations

@Arckenver Maybe you want to ajust the download links in this post, so the API-5.0.0 link refers to the latest download of the API 5 compatible build of Nations. Otherwise it seems like the 1.1 version is the right one.
Most people (including me) don’t always read all of the descriptions, but simply click the first link they can find on the download page :slight_smile:
Thanks :slight_smile: