UNMAINTAINED - 🌍 Nations [v2.5] - Towny-like protection plugin


#101

Hello,

When you think update this plugin to API 5 ? :slight_smile:


#102

As in players have '[rank][townname] Username' or maybe even [townname-leader (or mayor or something)]


Rent Plugin
#103

Sure. There's an issue for nation rank/grade system. For chat formatting, you'll need to get a plugin that uses NationsService to know in which nation the player is, if he is president etc.

As said above,

I know it is hard to wait, but please bare with it a little while more. Here's a little joke to help you wait.


Rent Plugin
#104

Thank you for your answer, I'm sorry for this question, I'm just so impatient :smiley:


#106

Yeah, so am I :smile:


#107

I've added Nation's support to SimpleTags. Will be releasing soon. It's still a work in progress.


#108

That would be nice of you :slight_smile:


#109

I actually decided to make it a separate add on for SimpleTags. I've never actually used Nations before so if something is missing or just doesn't make sense, suggestions are welcome.

https://github.com/trentech/SimpleTagsNations/releases/

Also yes I know both SimpleTags and SimpleTagsNations are built with API 5.0.0, however they are both 4.x compatible


#110

This is a awesome plugin and seems to work pretty much on API 5 up to the point of claiming land which i am unable to test since the golden axe throws and error when you try to right / left click to claim land. If this could be at least rectified then i am hoping that it continues to work as it has been so far. Creating and setting presidents disabling worlds all work fine on API 5 but the golden axe is the only issue so far that i am having.

[17:30:47] [Server thread/ERROR] [Sponge]: Could not pass InteractBlockEvent$Primary$MainHand$Impl to Plugin{id=com.arckenver.nations, name=Nations, version=0.10, description=A towny-like worldguard-like zone managment plugin., source=/home/minecraft/server/empyrean/mods/Nations-0.10.jar}
java.lang.NoSuchMethodError: org.spongepowered.api.entity.living.player.Player.getItemInHand()Ljava/util/Optional;
at com.arckenver.nations.listener.GoldenAxeListener.onPlayerLeftClick(GoldenAxeListener.java:56) ~[GoldenAxeListener.class:0.10]
at org.spongepowered.common.event.listener.PrimaryListener_GoldenAxeListener_onPlayerLeftClick157.handle(Unknown Source) ~[?:?]
at org.spongepowered.common.event.RegisteredListener.handle(RegisteredListener.java:95) ~[RegisteredListener.class:1.10.2-2092-5.0.0-BETA-1752]
at org.spongepowered.mod.event.SpongeModEventManager.post(SpongeModEventManager.java:353) [SpongeModEventManager.class:1.10.2-2092-5.0.0-BETA-1752]
at org.spongepowered.mod.event.SpongeModEventManager.post(SpongeModEventManager.java:336) [SpongeModEventManager.class:1.10.2-2092-5.0.0-BETA-1752]
at org.spongepowered.mod.event.SpongeModEventManager.post(SpongeModEventManager.java:381) [SpongeModEventManager.class:1.10.2-2092-5.0.0-BETA-1752]
at org.spongepowered.mod.event.SpongeModEventManager.post(SpongeModEventManager.java:366) [SpongeModEventManager.class:1.10.2-2092-5.0.0-BETA-1752]
at org.spongepowered.common.SpongeImpl.postEvent(SpongeImpl.java:141) [SpongeImpl.class:1.10.2-2092-5.0.0-BETA-1752]
at net.minecraft.network.NetHandlerPlayServer.redirect$handleLeftBlockClick$0(NetHandlerPlayServer.java:590) [me.class:?]
at net.minecraft.network.NetHandlerPlayServer.func_147345_a(NetHandlerPlayServer.java:631) [me.class:?]
at net.minecraft.network.play.client.CPacketPlayerDigging.func_148833_a(SourceFile:40) [ja.class:?]
at net.minecraft.network.play.client.CPacketPlayerDigging.func_148833_a(SourceFile:10) [ja.class:?]
at org.spongepowered.common.network.PacketUtil.onProcessPacket(PacketUtil.java:122) [PacketUtil.class:1.10.2-2092-5.0.0-BETA-1752]
at net.minecraft.network.PacketThreadUtil$1.redirect$onProcessPacket$0(SourceFile:39) [fl$1.class:?]
at net.minecraft.network.PacketThreadUtil$1.run(SourceFile:13) [fl$1.class:?]
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_101]
at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_101]
at net.minecraft.util.Util.func_181617_a(SourceFile:45) [h.class:?]
at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:668) [MinecraftServer.class:?]
at net.minecraft.server.dedicated.DedicatedServer.func_71190_q(DedicatedServer.java:387) [ld.class:?]
at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:613) [MinecraftServer.class:?]
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:471) [MinecraftServer.class:?]
at java.lang.Thread.run(Thread.java:745) [?:1.8.0_101]


#111

Thanks for your interest in Nations. I'll update Nations to API 5 as soon as possible.


#112

@Arckenver Thanks i just would love to have this available for my players when the server re opens but we will surely look at converting from polis to nations since nations does have a lot more features we are after. The only feature it lacks that i feel would be an improvement is the ability to claim the way you can with towny by claiming as you walk over the chunks you wish to claim.

Also a map feature like towny / factions would be helpful as a visual aid to nation admins to know where there borders are.

Thanks again for your work on this plugin it shows a lot of potential and glad its still being maintained and developed.


#113

Thanks for your kind words !

As you've noticed, the original idea of Nations was precisely a sponge equivalent of towny except for land claiming (using per-block instead of per-chunk claim system). The thing is to make such a system work, Nations must group claims in sets of rectangles. So unfortunately, a "as-you-walk" claim feature would not be possible...

For the map feature however, it could be possible but it would draw every block around you so not many of them. Not sure it's worth it, what do you guys think about that ?

Thanks for submitting ideas of features.


#114

@Arckenver the land claiming i thought would of been possible since it has been done by polis already and towny but at the end of the day its not a huge issue to live without but the map would be nice or at least some form of markers to mark the boundaries of the claimed area so to know exactly where your borders lie.

Looking forward to the update to api 5 .....I just curious is their any time frame of when the api 5 release may be coming i do know that you have said your busy with college but would be nice to know if this is something that is within the next couple of months or longer.

Cheers


#115

With the official announcement of the API 5 merge into master on october 15th, I can now officially announce Nations' first official release and release for API 5 on october 16th !

Thanks for your patience !


#116

I was testing out Nations, when all of a sudden I tried running the command /n leave as leader of the Nation. It said I couldn't do it, so I proceeded to do /na delete town. Then it says that the town does not exist. I can go over my previously claimed areas and it constantly tells me my town is there even though no commands work except /n here. I can create another town and interact like usual, but that claimed area is still there without existing through /n list or /n info.

As you can see here I ran the command /n list and then /n here right after. I thought this problem might be fixed with /na unclaim, but that command didn't exist. It would be great to have it in general if players were to claim areas you did not want them to claim.

EDIT

The error occurs when I have claimed land and I do /n leave. I get this message "Error occurred while executing command: null". Then the claimed land stays there, haven't tested server restart yet.


#117

Will this plugin work with Permission Manager?


#118

After restart, the town names re appeared. Though at this point I have personally created multiple towns at this point. I don't know what information I could provide that could help, but it's not ground breaking information. I don't know how this will effect info for other players when they are listed under multiple towns using this glitch.


#119

@Hidden308

Yes. Since v1.2 of PermissionManager, it even supports the home rule.

@NinjaMonkey

Can you give me the entire stacktrace of your Error occurred while executing command: null ?


#120

@Hidden308
PermissionManager can works with every plugins. The home rule works with Nations only with the v1.2. I'm waiting the new version of Nations to add it to PermissionManager.

@Arckenver
Does Nations works with Sponge API 4.2.0? If yes, I will add the supports.


#121

Oh you reminds me to put targeted sponge version in each github release.

Yes it does have SpongeAPI v4.2.0 as dependency.

Thanks for supporting it. :wink: