"Could not find or load main class GradleStart" .. meh!

Continuing the discussion from [Tutorial] Updated Eclipse Workspace Video - Mars + Buildship:

I fear this has been asked a million times already, but i couldn’t find anything useful:
I tried this, did everything exactly the same way and it looks everything the same way, until 6:40 in the Video.

When i try to run the client or the server from eclipse, i get this:
Error: Could not find or load main class GradleStart

I tried it on 2 different, quite new, Win 10 Systems with jdk1.8.0_74 and jre1.8.0_74 installed.
The SystemVar JAVA_HOME wasn’t set, but setting it to C:\Program Files\Java\jdk1.8.0_74 didn’t help.

I also tried running the setupDecompWorkspace and the eclipse task again. and this… but nothing :confused:

Do you have any other suggestions that i could try? =)

This probably won’t fix it, but I was under the assumption that JAVA_HOME needs to be set to ***/bin, so C:\Program Files\Java\jdk1.8.0_74\bin. Maybe, maybe not


@Socratic_Phoenix I tried it, just to be sure. But still the same issue. Thanks anyways =)

Okay … I got it working.
I think running setupDecompWorkspace and eclipse after changing the SystemVar to what @Socratic_Phoenix suggested, fixed it.

Whoo :slight_smile:
Ty for helping.

I have the same problem right now.
Can you help me with it ?

Holy necro … this was 7 years ago O.o

A lot has changed since then, so i’d suggest you make a new post and explain your issue as detailed as possible there, including all the versions you are using :slight_smile:

Maybe someone can help you there ^^
But this is definitely the wrong place :slight_smile:

While blue is right. We will also need to know your gradle version, what sponge your targetting (doubt it is the sponge 6 the video in reference is referring to)

Hehe i know its been a long time but i really need
Help and i dont think what worked 7 years ago wouldnt work now ¯⁠\⁠_⁠(⁠ツ⁠)⁠_⁠/⁠¯

Its a pretty old version (gradle 5.6)

Then create a new thread instead of replying to a 3 year old thread