CraftBook 4


#141

The parts of sponge that headdrops requires have not yet been implemented. Once they are implemented HeadDrops will start working without an update to CraftBook


#142

@me4502 really? Is it related to GameProfiles, or its it something else entirely?


#143

I haven't done a test recently, I'll do some testing and get back to you on IRC


#144

Hi there. I've loved Craftbook (and its IC's) since its Bukkit iterations.

I'm attempting to install "CraftBook-4.0-SNAPSHOT.jar" on my SpongeForge server.
SpongeForge version = spongeforge-1.8.9-1763-3.1.0-BETA-1181
Forge itself is version = forge-1.8.9-11.15.1.1763-universal
Java Platform Version is = 1.8.0_77 64-bit
Server OS is Windows 7

Other plugins:
PermissionsEx-Sponge
worldedit-force-mc1.8.9-6.1.1-dist

Although a config file does save to my server upon runtime, and Craftbook does seemingly install (meaning the server doesn't crash upon installation, and installation here means placing the Craftbook-4.0-SNAPSHOT.jar file in the mods folder, and upon closing and restarting the server batch file, it does create a config in a folder called "com.sk89q.craftbook" in the config folder, as well as a "craftbook-data" in the root directory), I am unable to place any ICs, which are something I was hoping I can have on this SpongeForge server. I looked at the .conf file and turned on all of the mechanisms that I can install and attempted to place them in the game using signs and levers, as I used to do in the Craftbukkit version... but they don't seem to work.

Possibly related, but when examining the server log, although the server doesn't crash, it generates the following error every few seconds:

-----[12:49:11] [Server thread/ERROR] [Sponge/]: Could not pass SendCommandEvent$Impl to Plugin{id=com.sk89q.craftbook, name=CraftBook, version=4.0}
java.lang.NoSuchMethodError: org.spongepowered.api.event.command.SendCommandEvent.setCommand(Ljava/lang/String;)V
at com.sk89q.craftbook.sponge.mechanics.variable.Variables.onCommandSend(Variables.java:190) ~[Variables.class:?]
at org.spongepowered.common.event.listener.SendCommandEventListener_Variables_onCommandSend10.handle(Unknown Source) ~[?:?]
at org.spongepowered.common.event.RegisteredListener.handle(RegisteredListener.java:86) ~[RegisteredListener.class:1.8.9-1763-3.1.0-BETA-1181]
at org.spongepowered.mod.event.SpongeModEventManager.post(SpongeModEventManager.java:238) [SpongeModEventManager.class:1.8.9-1763-3.1.0-BETA-1181]
at org.spongepowered.mod.event.SpongeModEventManager.post(SpongeModEventManager.java:282) [SpongeModEventManager.class:1.8.9-1763-3.1.0-BETA-1181]
at org.spongepowered.mod.event.SpongeModEventManager.post(SpongeModEventManager.java:250) [SpongeModEventManager.class:1.8.9-1763-3.1.0-BETA-1181]
at org.spongepowered.common.command.SpongeCommandManager.process(SpongeCommandManager.java:245) [SpongeCommandManager.class:1.8.9-1763-3.1.0-BETA-1181]
at net.minecraft.command.ServerCommandManager.func_71556_a(SourceFile:83) [bd.class:?]
at net.minecraft.server.dedicated.DedicatedServer.func_71333_ah(DedicatedServer.java:380) [ko.class:?]
at net.minecraft.server.dedicated.DedicatedServer.func_71190_q(DedicatedServer.java:345) [ko.class:?]
at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:605) [MinecraftServer.class:?]
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:481) [MinecraftServer.class:?]
at java.lang.Thread.run(Unknown Source) [?:1.8.0_77]


tl;dr although it seems to install, it creates errors every few ticks and nothing works. There's also no way to enter craftbook commands whether as an user or as a server console.

Help?


#145

You are using old versions of Forge and Sponge. Try Forge 1808 and Sponge 1279. That should work, provided you are using Java 8. Besides, not all features of Craftbook are working as yet. You need to try and see which ones have been implemented.

EDIT: You'll also need to download the craftbook.zip and unzip it - not the .jar


#146

Thanks for the explanation.
Ok so I updated Forge to forge-1.8.9-11.15.1.1855-universal.
I also updated Sponge to spongeforge-1.8.9-1808-4.1.0-BETA-1286.
I downloaded the ZIP file for Craftbook and unzipped it to the Mods folder, creating the following Jar files:
CraftBook-4.0-SNAPSHOPT
CraftBook-4.0-SNAPSHOT-javadoc
Craftboon-4.0-SNAPSHOT-sources
CraftBook-4.0-SNAPSHOT-original (which I had to remove from the Mods folder as it would cause an Server-Stopping issue).

Mechanics enabled:
-Variables
-Blockbag
-elevator
-snow
-bridge
-door
-gate
-footprints
-headdrops
-lightstone
-treelopper
-pipes
-icsocket
-glowstone
-netherrack
-jackolantern
-minecartemptydecau

All these loaded seemingly successfully (Anmeter failed as it would cause a tick on the server which, while not Server-Stopping, would constantly spit out errors in the console).

So... I guess I'm operational? However, things like Bridges ane Elevators, etc.are causing runtime errors like


[Server thread/ERROR] [Sponge]: Could not pass InteractBlockEvent$Secondary$Impl to org.spongepowered.mod.plugin.SpongeModPluginContainer@8b2991 java.util.NoSuchElementException: No value present
at java.util.Optional.get(Unknown Source) [?:1.8.0_77]
at com.sk89q.craftbook.sponge.mechanics.Elevator.onPlayerInteract(Elevator.java:87) ~[Elevator.class:?]

(followed by a bunch of lines of error for SpongeModEvent Manager and SecondaryListener and SpongeCommonEventFactory etc. etc. that, while don't stop the server from running, keep kicking up errors when my avatar attempts to create/interact with signs and the like)

Is there a list of what exactly works and what doesn't work yet? Do ICs like "Clock" and "Entity Sensor" work? The plugin has no way of letting me know it's working, aside from sponge telling me that it's installed using the /sponge plugins command.


#147

After this lecture I'll have a look at the plugin to ensure that its all updated for the latest version of sponge, however last time I checked (Two days ago) it was.

As for the currently implemented features, I'm trying to get sk to fix up the docs deployment


#148

Sweet, and thank you for the response.

I've been a huge fan of Craftbook and used it on my legacy 1.5.1 server.

Using the Entity Sensor combined with the "Toggle Area" mechanic, I was able to create a collapsing bridge that the player would have to outrun, and using it along with EntitySpawners would make for great "Arena Room" battles.

I was also able to use the "Clock" along with the "Entity Sensor" to create a poisoned water reservoir that a player would have to traverse without falling in the water (falling in would trigger Wither Status AND teleport the player back to the beginning of the area like oldtimey adventure games).

I eagerly await these features' return only with glorious 1.8.9 instead of ancient 1.5.1. :stuck_out_tongue:

Please continue working on this awesome plugin. We're all rooting for you!


#149

RE: PIPES: When you contact him, you may want to find out, what feature he proposes to use for filtering items to go into a single or a no of different chests when pipes get implemented


#150

So thankful that you've ported CraftBook to Sponge, THANK YOU!

I've got elevators and gates working just fine, but when I attempt to build a bridge (I've tried both cobblestone and wood) I get a "You can't use that material" message. Is there a config needed in the config file? And, if so, what is the exact syntax? I've tried a number of things including allowed-blocks=[COBBLESTONE,WOOD] but nothing seems to make it work. Any suggestions would be appreciated!


#151

There should be a config for it somewhere, as the CraftBook 4.0 wiki mentions it here. If that doesn't work, then something's wrong somewhere.


#152

Could you please provide a screenshot of the bridge?


#153

I think so too. But the config file that it starts with doesn't really have anything beside the data-only variable and the enabled/disabled variables. So, I'm not even sure how the config variable for materials should be formatted... for the record, I get the same message when I had no variable (which should go to the default).


#154

So, I thought I'd make a new one from scratch for a clean screen shot, and the bridge worked. I'm going to have to investigate more. So... bridges are working, but there's something about the original bridge I was trying that's not working right. It wasn't complicated, maybe a little long (12 blocks or so?)... but I get all sorts of different responses (can't find the other end, can't use that material) depending on where I place the signs (on face or on top of block)... let me do some more research so I can create something repeatable or recreateable before you waste any more time on me. Thanks for reaching out.


#155

So, it seems I was one over on the default max bridge length of 16 (mine was 17). Why it threw different messages at different times, I'm still not sure. So, I'm back to the config syntax issue again. What, precisely, do I need to put in the config file to increase the maximum bridge length? I've tried:
maximum-length=20
and
maximum-length=[20]
And neither of those seemed to make a difference.


#156

You're editing the bridge.conf file, right? You should be able to just change the number after maximum-length


#157

That's just it... there's nothing to help indicate how this thing is configed. Inside /config it created:

/com.sk89q.craftbook
  com.sk89q.craftbook.conf
  |
  --- /mechanics
      |
      -- Variables

the file Variables was empty and com.sk89q.craftbook.conf only had the two items, disabled-mechanics and enabled-mechanic. I have no other config files. That's why I'm so confused on how I'm supposed to configure it.


#158

Have you actually got bridges enabled? It should be creating the configuration files if they're enabled. It appears to be working fine for me.


#159

error


#160

I've just committed the fix. Should be here, http://builds.enginehub.org/job/craftbook, very soon.