CraftBook 4


#161

Still error.


#162

Okay, I've just fixed that one now too.


#163

When you try to put cobblestone next to the bridge


#164

The error occurs even if you just press the right mouse button.


#165

enabled-mechanics=[
HeadDrops,
...

Should you be creating a configuration file? I have not created and do not fall out of the head.


#166

Sorry, what do you mean?

I've fixed the errors you mentioned in the last comment.


#167

Sorry for my bad English. HeadDrops activated
[com.sk89q.craftbook]: Enabled: HeadDrops
but the head does not fall off. File .conf is missing.


#168

The file generates for me in all my testing. As for it not working, that's because Sponge doesn't support it properly yet.


#169

Thank you very much!


#170

OMG... I'm such a failure. I was just about to say there aren't any other conf files when it dawned on me that I was using WinSCP to look at the directories. And, even though I'd restarted the server numerous times, there seemed to be no new conf files... until I refreshed the directory in WinSCP. poof they were all there and suddenly everything made sense.

Thank you for your patience with me. And thanks for all the hard work you put into Minecraft! My kids and I love your additions!

Moral of the Story: use vi not WinSCP's text editor!


#171

Ah, yeah - I hate when that happens :stuck_out_tongue:

I'm glad everything worked out, and thanks :slight_smile:


#172

I am having issues getting configs to generate, and the plugin working. First run, it generated the main config. I enabled mechanics for just about everything. No config for head drops or IC's were created. The IC's were not working on the server even with permissions added to the group. I updated to build released yesterday. Still no IC's working. So i deleted configs and restarted. This time, the main config is empty except for variables being enabled. Also, should the config folder be named "com.sk89q.craftbook".
So i just restarted server again, and now the main config has disabled mechanics listed. Enabled a bunch of them again, and started up. Still no config for headdrops or ic's. Still unable to get ICs to work. I really love this plugin too. really hoping for some help here.
edit - console isn't showing any errors related to craftbook, /sponge plugins shows craftbook loaded. No commands are working.


#173

There are no config for headdrops or ICs, and headdrops are waiting on something to be implemented in sponge to work.

Which IC are you trying? Because only a few are implemented.


#174

Was hoping wireless ones were active. =transmitter =reciever as well as some of the entity detector ones.
and as for configs.. ok makes sence why they didn't generate. Is there a list of which ic's are active somewhere for the current version.. ic page on the new wiki has been blank for a lil while now.


#175

Any chance of getting more ICs implemented?


#176

I'll implement the two wireless ICs, I'm just not sure about the sensors. I'm still tossing up whether they should be a seperate mechanic, or to keep them as ICs.


#177

How i bind commands to items ?


#178

The CommandItems feature has not yet been ported to the Sponge version of the plugin.


#179

Able to proffer up an ETA on when Area functionality will ... function? ^_^


#180

Hi, is CB compatible with MC1.10 yet?