CraftBook 4


#181

I'll work on it next, so hopefully over the next few days if I get time.


#182

Last I tried, yes. However that was when the first few dev builds of 1.10 were released. It should still work however


#183

I'm afraid it doesn't ...

Edit: When I start the server after setting the configs, the enabled mechanics are reset and show only the Variables as enabled.


#184

Would you be so kind to add a command to reload the configuration of craftbook4. Perhaps something like "/cb reload"?


#186

Have you solved the config problem yet?


#187

I can't reproduce this issue, it's working perfectly for me.


#188

Yeah, I'll look into adding that.


Lift (There's an existing port but it does not work)
#189

when i try to download from the link added above, it shows me this page
https://dev.bukkit.org/bukkit-plugins/craftbook/files/
i know they are bukkit plugins but i tried 3.9s napshot for my 1.10.2 sponge server and nope its not working...
can u give a link for to download for 1.10.2 sponge...
PS. server says fml finds it as non-mod file but injects it...


#190

Where exactly did you find that link on here?

The correct download location is here, http://builds.enginehub.org/job/craftbook


#191

there are 5 files in there do i need to install 4 of them (not zip ofcourse)
cuz i tried with last build and first it said duplicate of files..
Please tell exactly which file i need cuz im kind of a newbie :smiley:
im using 1.10.2 sponge


#192

and i forgot to say that last build that sayd added chair didnt work... actually it crashed whole sponge mod :frowning:


#193

By the way i watched tutorial videos and i was like :scream: this is way more than i wanted :heart_eyes:
If we need worldedit for craftbook pls add its link too cuz there are different WE's for example: bukkit plugin worldedit, forge mod worldedit, im not sure if it exist but sponge worldedit...


#194

Use this one, http://builds.enginehub.org/job/craftbook/9359/download/CraftBook-4.0-SNAPSHOT.jar

What was the error that occurred when Chairs crashed Sponge? It worked in all of my local testing.

As for WorldEdit, it's currently only required for ToggleAreas, and even that is temporary. Once the Sponge Schematic API is completed I'll switch over to that.

This is a link to WorldEdit for Sponge: http://builds.enginehub.org/job/worldedit?branch=feature%2Fsponge-1.10.2


#195

You rock :grin: No crash :laughing:
guys use http://builds.enginehub.org/job/craftbook/9359/download/CraftBook-4.0-SNAPSHOT.jar for 1.10.2...


#196

I am using this wil 1.10.2 only other mod is pixelmon 5.0.0 beta 5

Loaded with no crash and generated config files. Shut down server, edited config files, restart server. Nothing works. No error or crash, sponge list the plugin in /sponge plugins but nothing I have configed is working. No trees falling with any axe, no head drop config file generated nor do they drop, glowstone doesn't turn off with redstone switches, can't sit in chairs, etc. It says everything is working and see the plugin as installed but seems to ignore it completely beyond that.

EDIT: Is the only documentation that may be of any help really in the form of youtube videos only! WHY!? I'm not sitting through videos. Write a text document with a full list of everything needed to make this plugin work! An example file of what all the configs should look like once generated. Add the plugins you only have videos of to the wiki (it says seriously check the wiki but seriously like 3 or 4 of the plugins included aren't even listed there. Still have no idea what netherrack does but saw it listed in the config!) TEXT TEXT TEXT, a good wiki contains A LOT of it. Videos are great but they are a luxury not a substitute for proper documentation. Sorry for the rant but I get so irritated with the trend on this site of not documenting your plugins. You're not the only one guilty of this and its SUPER annoying


#197

actually last night i just tried if its giving an crash or not and like Deathwhitch says there is no error and also nothing works...


#198

The documentation for CraftBook 4 contain no videos, http://enginehub.github.io/CraftBookDocs/index.html

It doesn't mention every feature yet as I've been very busy and haven't had time to write up the docs. All configurations and permissions should be documented though.

As for everything not working, could you please paste your startup log?


#199

Yeah I saw the documentation, the problem is its incomplete. there are videos on one of the pages, some for stuff you have no text about but i"m not watching all that . Documentation should be written as things are implemented and uploaded with the plugin itself. If you are saving your readme files and help files for last you shouldn't. Thats how you get behind. Work on those as you go.

As for my logs, again they show start up as normal. No errors or anything to report, just nothing working in game. I can see by the post above I am not the only one this is effecting. But yeah the logs show everything loaded just fine, yet nothing works in game


#200

I was asking about the logs, because CraftBook outputs for every mechanic that was enabled. Is it being outputted?


#201

it gives "a custom Databuilder is not extending abstractdatabuilder" error in a lot of times idk what it means and i have used a lot of plugins and mods... log file is too long to share...