[Discontinued] AdminShop [v1.8.2] - Server Shops


No problem.
Just for more information;

No changes in sponge were made.
Nothing out of the ordinary was changed.

Original shop file: 428 KB
New shop file: 396 KB

Varied between buy and sell signs.


Hey toothpick, were you by any chance having issue with your shop signs randomly deleting themselves?
I’m on 1222 and thinking of updating the server to 1233 and was wondering if it may help the issue.
Also in the newest forge build is /invsee working for you?


EDIT: can confirm that the latest sponge build as of today 1233 does not fix the inventory problem and people can still not see items in their hands, etc.


It works if you have an empty slot and you buy with it, but not if your holding an item and buy.


You can check the changelog of every build, or even look at Sponge’s GitHub to see what they changed.

They have not made ANY changes to their Inventory Implementation since March 27th.


Just tested and does not work for me unfortunately.

My shops are psychically being removed from the data file.
As I have mentioned before my shop files go from
Original shop file: 428 KB
New shop file: 396 KB
After every server restart.

I have to literally change out the file every time the server restarts or a number of my shops will remain broken and unusable. I am unsure why it wants to continue reverting back to the 396 KB deleted shop file when it loads.


Can I see the original shops.conf via PasteBin?



This is the original 428+ KB file


Hmm… and the one with some of them getting deleted?




Not sure if the temp shop that keeps being generated has to deal with this.


It probably does, please send me your log when shutting down the server after loading the original config.


I have signed on today with the file back to the 397k file,
However I decided to replace the file and delete the temp file and my original file still exists.

I then decided to restart the server myself to see if it would be effected, and it has still remained the original file.
Keeping in mind that no temp file has been generated yet either.

I will keep you updated on when/if it happens to switch back to the 397K file.



I’m almost positive removing that randomly generated temp. shop solved the problem.
I wonder if that was made when the files got auto-converted?


Unsure if this is an Admin Shop issue or Econlite, but if you do not have the funding to make a purchased from a sign, it no longer displays a “You do not have enough funds to make this purchase”. Instead it just simply doesn’t display anything which are leaving players to believe the signs are broken again x3

However, other econ related messages are popping up such as “You have successfully purchased BLANK for BLANK”


Okay, I’ll check it out. :slight_smile:


Release v1.7c

Tested on SpongeForge 1251


  • Bug fixes with Economy messages not showing up all the time.



Sponge 1233
AdminShop 1.7c

Issue happened again where a random temp shop was developed and our shop files went from 417KB to 141KB

However, we did a lot of editing to our shops about a week ago… but I don’t think editing them caused a new temp file a week after?

EDIT: actually could moving from 1251 back down to 1233 effect this? We had a lot of issues with 1251 messing up plugins so we had to go back.


Not sure what it’s caused by either - but that COULD be related :confused:


No biggy.
Doesn’t happen often enough once the temp file is removed to bother me.

As long as people make backups (as all server owners should daily) then there shouldn’t ever be a major problem.


I created a new world separate altogether from the one I am playing on for testing purposes. When I log into my play world again, the Admin Shop isn’t working any longer and I have to enter the commands for the signs all over again! Is this a BUG, perhaps?