Kits [v1.7.4]

PLEASE HELP! I gave the groups their kit (Member: kits.use.member, kits.use and kits.use.daily) and they have access to use every kit in the server! HELP!!

To deny the other kits you would have to have permissions denying them. For example:

"kits.use.daily": 1,
"kits.use.otherkit1": -1,
"kits.use.otherkit2": -1,
"kits.use.otherkit3": -1,
"kits.use.otherkit4": -1,
"kits.use.otherkit5": -1,

-1 = Deny
1 = Allow

How do i add custom mod items?

I personally use this with Pixelmon’s items, and it works in the very same way - pixelmon:PokeBall is the complete item ID that I used. So you’d need to get the complete and exact ID for the item you would want to use.

signs arent working unless you are oped

Because you need to assign permissions? Head over to PEX 2.0’s page, it’s a permission manager. There, you will be able to give permissions to groups and individual players, but it will remove the OP system.

If your sign is at spawn and you have spawn protection on that’ll screw with it. Go into the and disable that, and make sure your users have the permission to use the signs.

any way to add custom enchanted weapons to a kit?

1 Like

as well as how do i add dyed items

1 Like

@HassanS6000 I’ve run into a particular issue a few times now and haven’t a clue on how to fix it. The versions of everything I’m currently running on my server are as follows, 1.7.4 Kits, 1.8.9 MC, 4.2.7 Pixelmon, spongeforge-1.8.9-1890-4.2.0-BETA-1653 SpongeForge. This issue has happened around 3 or 4 times for me. I have Donation ranks purchasable on my server, and each rank comes with a custom kit that one can use every 48 hours. Originally I didn’t know you could change the time parameter so I had it as 48 hours, but it seconds. First use of the kit worked just fine, but when it came around the time which a person would use it again they’d see a time not proper considering how long its been since first use. IE something along the lines of 136123 seconds when it should be closer to 3600/60 minutes. When they’d try to do it again they’d see the same time over and over, with it being stuck at the time. I’ve tried use the kit reset command but after using that they were told they can’t use this kit right now. I then tried to change it from seconds to hours, which worked for me who had not used the kit thus yet and told me 47 hours until kit can be used again, but for the player who had used it, it told him that 163002 Hours need to pass before he can use the kit again. I’m lost with why this is happening so any insight is appreciated.

It seems Cooldowns are resetting after every server restart on API 5 MC 1.10.2

Times are being saved on an event that isn’t getting reached. Just fixed the issue for a server owner who paid me. I’ll got submit a pull request. ^^

Bug has been fixed, releasing soon

How do you add enchantments to the items please :smiley:

How do i add items that are not in minecraft like pixelmon

Use the pixelmon item’s ID. They start with pixelmon:

the time on one kit for a player isnt depleting do you know how i can fix this? i have tried /kit reset

Can we get an API 5 build?

Kits was discontinued. You should look to Nucleus, which Hassan and dualspiral have both worked on. It does carry a kit module.

Nucleus was broken for me and I don’t like the way it works. I wanted a seperate kit plugin.